aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3stat
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
commitbb271f0bf7b513a23a31da4ec8819b113ebf4587 (patch)
treeac5a462edc3d85d5f0b20a594802ce4b12f0bf9f /audio/mp3stat
parent29879aded766da253313579a3503ff5e15026355 (diff)
downloadports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.tar.gz
ports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.zip
Convert ports to use the options helpers in categories [abc]*, and minor fixes.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3412?
Notes
Notes: svn path=/head/; revision=394778
Diffstat (limited to 'audio/mp3stat')
-rw-r--r--audio/mp3stat/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/audio/mp3stat/Makefile b/audio/mp3stat/Makefile
index 43a59707a995..4e164d6a7bd4 100644
--- a/audio/mp3stat/Makefile
+++ b/audio/mp3stat/Makefile
@@ -32,14 +32,9 @@ PLIST_FILES= bin/mp3stat \
lib/mp3stat/ui_gtk2.so \
lib/mp3stat/ui_console.so
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
-PLIST_FILES+= lib/mp3stat/input_vorb.so
-.else
-MAKE_ARGS+= VORBIS=""
-.endif
+VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
+VORBIS_PLIST_FILES= lib/mp3stat/input_vorb.so
+VORBIS_MAKE_ARGS_OFF= VORBIS=""
post-patch:
@${FIND} ${WRKSRC} -name "Makefile*" | ${XARGS} ${REINPLACE_CMD} -e \
@@ -59,11 +54,10 @@ do-install:
${STAGEDIR}${PREFIX}/lib/mp3stat)
(cd ${WRKSRC}/input/mp3 && ${INSTALL_LIB} input_mp3.so \
${STAGEDIR}${PREFIX}/lib/mp3stat)
-.if ${PORT_OPTIONS:MVORBIS}
- (cd ${WRKSRC}/input/vorbis && ${INSTALL_LIB} input_vorb.so \
- ${STAGEDIR}${PREFIX}/lib/mp3stat)
-.endif
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} README ${STAGEDIR}${DOCSDIR})
+do-install-VORBIS-on:
+ (cd ${WRKSRC}/input/vorbis && ${INSTALL_LIB} input_vorb.so \
+ ${STAGEDIR}${PREFIX}/lib/mp3stat)
.include <bsd.port.mk>