aboutsummaryrefslogtreecommitdiff
path: root/audio/muine
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-10-13 01:58:56 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-10-13 01:58:56 +0000
commit5b2e2090440f89ef8ef87b4f514cb98fd04e50b8 (patch)
treed1cf0327ff3c423d1dcaa03289b6511e0efefdd7 /audio/muine
parent0a2353a0be95259a8eee7c81b218bdec38ffa01d (diff)
downloadports-5b2e2090440f89ef8ef87b4f514cb98fd04e50b8.tar.gz
ports-5b2e2090440f89ef8ef87b4f514cb98fd04e50b8.zip
[Maintainer Update] Muine: Fix library mapping so minor updates don't cause breakage.
Attached patch changes Muine's library mappings so minor version number changes do not break the port in the future. PR: ports/71136 Submitted by: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
Notes
Notes: svn path=/head/; revision=119139
Diffstat (limited to 'audio/muine')
-rw-r--r--audio/muine/Makefile8
-rw-r--r--audio/muine/files/patch-src_muine.exe.config.in4
2 files changed, 3 insertions, 9 deletions
diff --git a/audio/muine/Makefile b/audio/muine/Makefile
index 6e25259aafda..588cdb89cfd1 100644
--- a/audio/muine/Makefile
+++ b/audio/muine/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= xine.9:${PORTSDIR}/multimedia/libxine \
id3tag.2:${PORTSDIR}/audio/libid3tag \
gdbm:${PORTSDIR}/databases/gdbm
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gtk-sharp.pc:${PORTSDIR}/x11-toolkits/gtk-sharp
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gtk-sharp.pc:${PORTSDIR}/x11-toolkits/gtk-sharp
+RUN_DEPENDS= ${BUILD_DEPENDS}
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack intltool libgnomeui
@@ -28,10 +28,4 @@ USE_REINPLACE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-GLIB_MIVER= 400
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%GLIB_MIVER%%|${GLIB_MIVER}|g' \
- ${WRKSRC}/src/muine.exe.config.in
-
.include <bsd.port.mk>
diff --git a/audio/muine/files/patch-src_muine.exe.config.in b/audio/muine/files/patch-src_muine.exe.config.in
index 9006c188b055..6eb9c6d7cb81 100644
--- a/audio/muine/files/patch-src_muine.exe.config.in
+++ b/audio/muine/files/patch-src_muine.exe.config.in
@@ -4,8 +4,8 @@
<configuration>
- <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so.0"/>
- <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so.0"/>
-+ <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so.%%GLIB_MIVER%%"/>
-+ <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so.%%GLIB_MIVER%%"/>
++ <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so"/>
++ <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so"/>
<dllmap dll="libgnomevfs-2.dll" target="libgnomevfs-2.so"/>
<dllmap dll="libmuine" target="@prefix@/lib/muine/libmuine.so"/>
</configuration>