aboutsummaryrefslogtreecommitdiff
path: root/audio/muine
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-11-26 06:45:43 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-11-26 06:45:43 +0000
commitb87739694789ace73d8b01f783dc88296a5969c3 (patch)
treeaf5d01177ac371f3ccd650294324a109918ed88e /audio/muine
parent9f0e255d09a148fa3d1b8eb90740fe85528b4501 (diff)
downloadports-b87739694789ace73d8b01f783dc88296a5969c3.tar.gz
ports-b87739694789ace73d8b01f783dc88296a5969c3.zip
- Add an OPTION to use gstreamer over xine as the playback backend. Xine is
still default. - Use new GCONF_SCHEMAS PR: ports/74399 Submitted by: Tom McLaughlin <tmclaugh@sdf.lonestar.org> (maintainer) Project by: BSD# - http://forge.novell.com/modules/xfmod/project/?bsd-sharp
Notes
Notes: svn path=/head/; revision=122486
Diffstat (limited to 'audio/muine')
-rw-r--r--audio/muine/Makefile24
-rw-r--r--audio/muine/pkg-plist3
2 files changed, 18 insertions, 9 deletions
diff --git a/audio/muine/Makefile b/audio/muine/Makefile
index 6fcc5d3a6f2d..6fdcba278331 100644
--- a/audio/muine/Makefile
+++ b/audio/muine/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: muine
# Date created: 20040615
-# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
#
@@ -14,19 +14,31 @@ MASTER_SITES= http://muine.gooeylinux.org/
MAINTAINER= tmclaugh@sdf.lonestar.org
COMMENT= Mono based Gnome audio player
-LIB_DEPENDS= xine.9:${PORTSDIR}/multimedia/libxine \
- FLAC.5:${PORTSDIR}/audio/flac \
+LIB_DEPENDS= FLAC.5:${PORTSDIR}/audio/flac \
id3tag.2:${PORTSDIR}/audio/libid3tag \
gdbm:${PORTSDIR}/databases/gdbm
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gtk-sharp.pc:${PORTSDIR}/x11-toolkits/gtk-sharp
+BUILD_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack intltool libgnomeui
+USE_X_PREFIX= yes
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+GCONF_SCHEMAS= muine.schemas
+
+OPTIONS= GSTREAMER "Enable Gstreamer backend" off
+
+.include <bsd.port.pre.mk>
+
+.if defined (WITH_GSTREAMER)
+CONFIGURE_ARGS+= --enable-gstreamer=yes
+USE_GNOME+= gstreamerplugins
+.else
+LIB_DEPENDS+= xine.9:${PORTSDIR}/multimedia/libxine
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/muine/pkg-plist b/audio/muine/pkg-plist
index 1fffc73720c3..50064d960b9c 100644
--- a/audio/muine/pkg-plist
+++ b/audio/muine/pkg-plist
@@ -1,7 +1,4 @@
bin/muine
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/muine.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/muine.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/muine.schemas > /dev/null || /usr/bin/true
lib/muine/AmazonSearchService.dll
lib/muine/libmuine.a
lib/muine/libmuine.so