aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpd/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-05-04 15:41:40 +0000
committerChris Rees <crees@FreeBSD.org>2013-05-04 15:41:40 +0000
commite1fae8eeef2a14681697e03213b0cc8892a61e7a (patch)
tree67c783b2408a4d66cffd5796406a35da044de581 /audio/musicpd/Makefile
parentda9ddd338b4dc88c8aae8614d2889d7a2414a4e6 (diff)
downloadports-e1fae8eeef2a14681697e03213b0cc8892a61e7a.tar.gz
ports-e1fae8eeef2a14681697e03213b0cc8892a61e7a.zip
audio/musicpd: Add support for bonjour/mDNSResponder
PR: ports/178274 Submitted by: Matthieu Volat <mazhe@alkumuna.eu>
Notes
Notes: svn path=/head/; revision=317325
Diffstat (limited to 'audio/musicpd/Makefile')
-rw-r--r--audio/musicpd/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 1b051ba1832a..4311c048cbfa 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -34,9 +34,11 @@ PORTDOCS= AUTHORS README COPYING NEWS UPGRADING
SUB_FILES= pkg-message
-OPTIONS_DEFINE= ID3TAG IPV6 AVAHI FLAC VORBIS WAV FFMPEG TREMOR AAC \
+OPTIONS_DEFINE= ID3TAG IPV6 FLAC VORBIS WAV FFMPEG TREMOR AAC \
MUSEPACK MIKMOD MODPLUG ARCHIVE MMS LASTFM AO PULSEAUDIO \
JACK SHOUTCAST SNDFILE LAME HTTPD SAMPLERATE CUE
+OPTIONS_RADIO= ZEROCONF
+OPTIONS_RADIO_ZEROCONF= AVAHI MDNSRESPONDER
OPTIONS_DEFAULT=ID3TAG IPV6 FLAC VORBIS WAV FFMPEG SNDFILE
LAME_DESC= Support for MP3 Icecast Streams
@@ -179,6 +181,13 @@ LIB_DEPENDS+= avahi-client.3:${PORTSDIR}/net/avahi-app
CONFIGURE_ARGS+=--with-zeroconf=no
.endif
+.if ${PORT_OPTIONS:MMDNSRESPONDER}
+CONFIGURE_ARGS+=--with-zeroconf=bonjour
+LIB_DEPENDS+= dns_sd:${PORTSDIR}/net/mDNSResponder
+.else
+CONFIGURE_ARGS+=--with-zeroconf=no
+.endif
+
.if ${PORT_OPTIONS:MAO}
CONFIGURE_ARGS+=--enable-ao
LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao