aboutsummaryrefslogtreecommitdiff
path: root/audio/ocp/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-24 14:11:31 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-24 14:11:31 +0000
commit8e2b69549d4416e9b2177ae1a58b4ec624c15390 (patch)
treeda1ecd4a75fa442a0f8ddfdb5d13103e9e3b8fd8 /audio/ocp/Makefile
parentc88dce56eca1199ae7360d921796152a5e55c0e4 (diff)
downloadports-8e2b69549d4416e9b2177ae1a58b4ec624c15390.tar.gz
ports-8e2b69549d4416e9b2177ae1a58b4ec624c15390.zip
Open Cubic Player first appeared around December 1994 as a DOS
binary-only module player. It supported many soundcards and module formats. At some point, the source code was released to the public under the terms of the GNU General Public License, and around 2003 Stian Skjelstad ported the code to Linux. In addition to legacy tracker formats such as mod, xm and s3m, Open Cubic Player now also supports mp3 and ogg files. PR: ports/80276 Submitted by: Emanuel Haupt <ehaupt@critical.ch> Approved by: adamw (mentor)
Notes
Notes: svn path=/head/; revision=134061
Diffstat (limited to 'audio/ocp/Makefile')
-rw-r--r--audio/ocp/Makefile70
1 files changed, 70 insertions, 0 deletions
diff --git a/audio/ocp/Makefile b/audio/ocp/Makefile
new file mode 100644
index 000000000000..e26bf8df93f2
--- /dev/null
+++ b/audio/ocp/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: ocp
+# Date created: 22 April 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ocp
+PORTVERSION= 0.1.5
+CATEGORIES= audio
+MASTER_SITES= http://labs.nixia.no/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= The legendary Open Cubic Player
+
+LIB_DEPENDS= sidplay.1:${PORTSDIR}/audio/libsidplay \
+ id3tag.2:${PORTSDIR}/audio/libid3tag \
+ mad.2:${PORTSDIR}/audio/libmad \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+ONLY_FOR_ARCHS= i386
+
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_GCC= 3.4+
+
+CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|@LIBDIR@|${PREFIX}/lib/ocp|' \
+ ${WRKSRC}/Rules.make.in
+ @${REINPLACE_CMD} -e 's|stdint\.h|inttypes\.h|' ${WRKSRC}/types.h
+ @${REINPLACE_CMD} -e 's|ocp-" VERSION|ocp"|' \
+ ${WRKSRC}/boot/kickload.c
+ @${REINPLACE_CMD} -e 's|\(-shared\)|-L${LOCALBASE}/lib -L${X11BASE}/lib \1|' \
+ ${WRKSRC}/playmp2/Makefile \
+ ${WRKSRC}/playogg/Makefile \
+ ${WRKSRC}/playsid/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ocp ${PREFIX}/bin
+ ${CHMOD} u+s ${PREFIX}/bin/ocp
+
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/cp.pak ${DATADIR}
+
+ ${INSTALL_DATA} ${WRKSRC}/ocp.ini ${PREFIX}/etc/ocp.ini.default
+.if !exists(${PREFIX}/etc/ocp.ini)
+ ${INSTALL_DATA} ${WRKSRC}/ocp.ini ${PREFIX}/etc
+.endif
+
+ ${MKDIR} ${PREFIX}/lib/ocp
+ ${INSTALL_DATA} ${WRKSRC}/*.so ${PREFIX}/lib/ocp
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in AUTHORS BUGS CREDITS Changelog KEYBOARD_REMAPS SUID TODO
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>