aboutsummaryrefslogtreecommitdiff
path: root/audio/openal-soft
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2012-10-24 18:08:50 +0000
committerMarcus von Appen <mva@FreeBSD.org>2012-10-24 18:08:50 +0000
commit7a8f18dc89525c7222b87d5ae35ae487e32c2af4 (patch)
tree2fb9b3853e6bc1c8f2e25ac8577892da618f2b67 /audio/openal-soft
parent5b2b0deb9b0df463cfbd6519b185fb39c84b0f1e (diff)
downloadports-7a8f18dc89525c7222b87d5ae35ae487e32c2af4.tar.gz
ports-7a8f18dc89525c7222b87d5ae35ae487e32c2af4.zip
- Fix OSS device detection
- Convert to OptionsNG - Trim Makefile headers PR: ports/173019 Submitted by: Sergei <nbspjr@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=306351
Diffstat (limited to 'audio/openal-soft')
-rw-r--r--audio/openal-soft/Makefile17
-rw-r--r--audio/openal-soft/files/patch-Alc_backends_oss.c11
2 files changed, 18 insertions, 10 deletions
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
index abe981909e9f..666cc469e8ae 100644
--- a/audio/openal-soft/Makefile
+++ b/audio/openal-soft/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: openal-soft
-# Date created: 2009-02-01
-# Whom: Marcus von Appen <mva@sysfault.org>
-#
# $FreeBSD$
-#
PORTNAME= openal-soft
PORTVERSION= 1.14
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://kcat.strangesoft.net/openal-releases/
@@ -21,12 +17,13 @@ USE_LDCONFIG= yes
CMAKE_ARGS+= -DALSA:BOOL=OFF -DPORTAUDIO:BOOL=OFF -DSOLARIS:BOOL=OFF \
-DDSOUND:BOOL=OFF -DALSOFT_CONFIG:BOOL=ON -DEXAMPLES:BOOL=OFF
-OPTIONS= PULSEAUDIO "Enable sound streaming using PulseAudio" off
+OPTIONS_DEFINE= PULSEAUDIO
+PULSEAUDIO_DESC= Enable sound streaming using PulseAudio
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PULSEAUDIO)
-LIB_DEPENDS+= pulse-simple.0:${PORTSDIR}/audio/pulseaudio
+.if ${PORT_OPTIONS:MPULSEAUDIO}
+LIB_DEPENDS+= pulse-simple:${PORTSDIR}/audio/pulseaudio
CFLAGS+= -Iinclude -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CMAKE_ARGS+= -DPULSEAUDIO:BOOL=ON
@@ -41,4 +38,4 @@ post-patch:
@${REINPLACE_CMD} 's|alsoft.conf|alsoft.conf.sample|' \
${WRKSRC}/CMakeLists.txt
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/openal-soft/files/patch-Alc_backends_oss.c b/audio/openal-soft/files/patch-Alc_backends_oss.c
new file mode 100644
index 000000000000..20514bf85295
--- /dev/null
+++ b/audio/openal-soft/files/patch-Alc_backends_oss.c
@@ -0,0 +1,11 @@
+--- Alc/backends/oss.c.orig 2012-03-28 17:55:17.000000000 +0200
++++ Alc/backends/oss.c 2012-04-22 14:13:19.000000000 +0200
+@@ -511,7 +511,7 @@
+ {
+ #ifdef HAVE_STAT
+ struct stat buf;
+- if(stat(oss_device, &buf) == 0)
++ if(stat(oss_driver, &buf) == 0)
+ #endif
+ AppendAllDeviceList(oss_device);
+ }