aboutsummaryrefslogtreecommitdiff
path: root/audio/openal-soft
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-03-06 16:30:22 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-03-06 16:30:22 +0000
commitd754f15cf9775d4dc879bd9ccbf9e1173ee8aa6c (patch)
treec51860e4591d8a84831d457970cdb6c1298d1016 /audio/openal-soft
parentd2617f45420d3bec2a08198b6de3a0304563b576 (diff)
downloadports-d754f15cf9775d4dc879bd9ccbf9e1173ee8aa6c.tar.gz
ports-d754f15cf9775d4dc879bd9ccbf9e1173ee8aa6c.zip
audio/openal-soft: allow to build the port without the utilities
This helps to avoid dependency on `audio/libmysofa' and thus not to download its quite heavy ~190 MB distfile.
Diffstat (limited to 'audio/openal-soft')
-rw-r--r--audio/openal-soft/Makefile13
-rw-r--r--audio/openal-soft/pkg-plist4
2 files changed, 10 insertions, 7 deletions
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
index f780656de5ef..6674bc2840da 100644
--- a/audio/openal-soft/Makefile
+++ b/audio/openal-soft/Makefile
@@ -10,15 +10,13 @@ COMMENT= Software implementation of the OpenAL specification
LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libmysofa.so:audio/libmysofa
-
USES= cmake compiler:c++14-lang tar:bzip2
USE_LDCONFIG= yes
CMAKE_ARGS= -DCMAKE_INSTALL_DATADIR:STRING="${PREFIX}/etc"
CMAKE_OFF= ALSOFT_BACKEND_ALSA ALSOFT_DLOPEN ALSOFT_EXAMPLES \
ALSOFT_REQUIRE_QSA ALSOFT_REQUIRE_SOLARIS
-CMAKE_ON= ALSOFT_BACKEND_WAVE ALSOFT_UTILS
+CMAKE_ON= ALSOFT_BACKEND_WAVE
# do not link with librt and libdl.
LDFLAGS+= -Wl,--as-needed
@@ -26,11 +24,13 @@ LDFLAGS_i386= -Wl,-z,notext
PLIST_SUB= SOVERSION=${PORTVERSION}
-OPTIONS_DEFINE= CONFIG EXAMPLES JACK OSS PORTAUDIO PULSEAUDIO SDL SNDIO
-OPTIONS_DEFAULT= OSS
+OPTIONS_DEFINE= CONFIG EXAMPLES JACK OSS PORTAUDIO PULSEAUDIO \
+ SDL SNDIO UTILS
+OPTIONS_DEFAULT= OSS UTILS
OPTIONS_SUB= yes
CONFIG_DESC= Install configuration utility (needs Qt 5)
+UTILS_DESC= Build and install utility programs
CONFIG_USES= qt:5
CONFIG_USE= QT=core,gui,widgets,buildtools_build,qmake_build
@@ -55,6 +55,9 @@ SDL_CMAKE_BOOL= ALSOFT_BACKEND_SDL2 ALSOFT_REQUIRE_SDL2
SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
SNDIO_CMAKE_BOOL= ALSOFT_BACKEND_SNDIO ALSOFT_REQUIRE_SNDIO
+UTILS_LIB_DEPENDS= libmysofa.so:audio/libmysofa
+UTILS_CMAKE_BOOL= ALSOFT_UTILS
+
post-patch:
@${REINPLACE_CMD} 's|/etc/openal|${ETCDIR}|' \
${WRKSRC}/alc/alconfig.cpp
diff --git a/audio/openal-soft/pkg-plist b/audio/openal-soft/pkg-plist
index 08321dfbc00a..ac89f5532261 100644
--- a/audio/openal-soft/pkg-plist
+++ b/audio/openal-soft/pkg-plist
@@ -1,6 +1,6 @@
%%CONFIG%%bin/alsoft-config
-bin/makemhr
-bin/openal-info
+%%UTILS%%bin/makemhr
+%%UTILS%%bin/openal-info
%%ETCDIR%%/alsoftrc.sample
%%ETCDIR%%/hrtf/Default HRTF.mhr
%%ETCDIR%%/presets/3D7.1.ambdec