aboutsummaryrefslogtreecommitdiff
path: root/audio/openal
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-09-26 12:12:49 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-09-26 12:12:49 +0000
commit4d27f73f4fbaceeea75b95febdb3a0da1b3e2b47 (patch)
tree3527e0ccf3cde30148a2855796f769c8b1c6002c /audio/openal
parent22d7e4fb5818d28c806dac0d4ceebc52715ba32e (diff)
downloadports-4d27f73f4fbaceeea75b95febdb3a0da1b3e2b47.tar.gz
ports-4d27f73f4fbaceeea75b95febdb3a0da1b3e2b47.zip
New port openal, a 3D sound library.
Notes
Notes: svn path=/head/; revision=33138
Diffstat (limited to 'audio/openal')
-rw-r--r--audio/openal/Makefile26
-rw-r--r--audio/openal/distinfo1
-rw-r--r--audio/openal/files/patch-configure.in11
-rw-r--r--audio/openal/files/patch-src:alc:alc_context.c22
-rw-r--r--audio/openal/files/patch-src:threads:posixthreads.c11
-rw-r--r--audio/openal/pkg-comment1
-rw-r--r--audio/openal/pkg-descr10
-rw-r--r--audio/openal/pkg-plist14
8 files changed, 96 insertions, 0 deletions
diff --git a/audio/openal/Makefile b/audio/openal/Makefile
new file mode 100644
index 000000000000..f2ce83b95e7e
--- /dev/null
+++ b/audio/openal/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: openal
+# Date created: 25 September 2000
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openal
+PORTVERSION= 20000908
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.openal.org/
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/linux
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ for file in $$(find ${WRKSRC} -name Makefile.in); \
+ do \
+ perl -pi -e 's/-g -c/-c/g' $${file}; \
+ done
+
+.include <bsd.port.mk>
diff --git a/audio/openal/distinfo b/audio/openal/distinfo
new file mode 100644
index 000000000000..37681d89b9ae
--- /dev/null
+++ b/audio/openal/distinfo
@@ -0,0 +1 @@
+MD5 (openal-20000908.tar.gz) = f8940f253b738a4c29f2d3dc09fb4936
diff --git a/audio/openal/files/patch-configure.in b/audio/openal/files/patch-configure.in
new file mode 100644
index 000000000000..adb925b2f90c
--- /dev/null
+++ b/audio/openal/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in~ Sat Sep 9 00:15:48 2000
++++ configure.in Mon Sep 25 18:53:56 2000
+@@ -111,7 +111,7 @@
+ AC_CHECK_LIB(m, sin, LIBS="$LIBS -lm", echo "I'm afraid you'll need libm."; exit 1)
+
+ dnl Should be allow dlopen of extensions?
+-AC_CHECK_LIB(dl, dlopen, LIBS="$LIBS -ldl", AC_DEFINE(NODLOPEN) echo "Can't dlopen extensions." )
++AC_CHECK_FUNC(dlopen, [], AC_CHECK_LIB(dl, dlopen, LIBS="$LIBS -ldl", AC_DEFINE(NODLOPEN) echo "Can't dlopen extensions." ))
+
+ dnl Special OS objs for target systems
+ case "$target" in
diff --git a/audio/openal/files/patch-src:alc:alc_context.c b/audio/openal/files/patch-src:alc:alc_context.c
new file mode 100644
index 000000000000..e39fce269521
--- /dev/null
+++ b/audio/openal/files/patch-src:alc:alc_context.c
@@ -0,0 +1,22 @@
+--- src/alc/alc_context.c~ Tue Aug 1 02:10:18 2000
++++ src/alc/alc_context.c Mon Sep 25 19:20:23 2000
+@@ -65,7 +65,7 @@
+ static ALCenum _alcDestroyContext(AL_context *cc);
+ static void _alcReallocContexts(ALuint newsize);
+ static int _alcCidToIndex(ALuint cid);
+-static ALuint _alcIndexToCid(int index);
++static ALuint _alcIndexToCid(int idx);
+
+ #ifdef JLIB
+ unsigned int jlib_debug = 0;
+@@ -777,8 +777,8 @@
+ return cid - CONTEXT_BASE;
+ }
+
+-static ALuint _alcIndexToCid(int index) {
+- return index + CONTEXT_BASE;
++static ALuint _alcIndexToCid(int idx) {
++ return idx + CONTEXT_BASE;
+ }
+
+ /*
diff --git a/audio/openal/files/patch-src:threads:posixthreads.c b/audio/openal/files/patch-src:threads:posixthreads.c
new file mode 100644
index 000000000000..c322d396e4ae
--- /dev/null
+++ b/audio/openal/files/patch-src:threads:posixthreads.c
@@ -0,0 +1,11 @@
+--- src/threads/posixthreads.c~ Mon Aug 28 19:14:08 2000
++++ src/threads/posixthreads.c Mon Sep 25 19:17:19 2000
+@@ -82,7 +82,7 @@
+ }
+
+ extern unsigned int Posix_SelfThread(void) {
+- return (unsigned int) pthread_self();
++ return (unsigned long)(unsigned long *) pthread_self();
+ }
+
+ extern void Posix_ExitThread(UNUSED(int retval)) {
diff --git a/audio/openal/pkg-comment b/audio/openal/pkg-comment
new file mode 100644
index 000000000000..9ea8df663bd7
--- /dev/null
+++ b/audio/openal/pkg-comment
@@ -0,0 +1 @@
+A 3D positional spatialized sound library
diff --git a/audio/openal/pkg-descr b/audio/openal/pkg-descr
new file mode 100644
index 000000000000..5d0059fc56ec
--- /dev/null
+++ b/audio/openal/pkg-descr
@@ -0,0 +1,10 @@
+The idea behind OpenAL is a 3d positional spatialized sound library analogous
+to OpenGL: instead of micromanaging each aspect of sound playback and effect,
+the application writer may limit themselves to placing the sounds in the
+scene and letting the native OpenAL implementation determine the correct
+amount of pitch alteration, gain attenuation, phase shift, etc, required to
+render the sounds correctly.
+
+That's the goal, anyway.
+
+WWW: http://www.openal.org/
diff --git a/audio/openal/pkg-plist b/audio/openal/pkg-plist
new file mode 100644
index 000000000000..852b25fe2aaf
--- /dev/null
+++ b/audio/openal/pkg-plist
@@ -0,0 +1,14 @@
+include/AL/al.h
+include/AL/alc.h
+include/AL/alu.h
+include/AL/alut.h
+include/AL/altypes.h
+include/AL/alctypes.h
+include/AL/alutypes.h
+include/AL/aluttypes.h
+include/AL/alkludge.h
+include/AL/alkludgetypes.h
+lib/libopenal.so
+lib/libopenal.so.0
+lib/libopenal.so.0.0.4
+@dirrm include/AL