aboutsummaryrefslogtreecommitdiff
path: root/audio/oss
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2011-07-25 17:45:00 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2011-07-25 17:45:00 +0000
commit36fb73325e927a955e64cd5d3ee6db6526165f15 (patch)
tree32ef249680f7b005791ca17f3ee4d2c2cb2a59f0 /audio/oss
parent1910f8ae15a1726661ed23250aafc09dd8a7d7b3 (diff)
downloadports-36fb73325e927a955e64cd5d3ee6db6526165f15.tar.gz
ports-36fb73325e927a955e64cd5d3ee6db6526165f15.zip
Fix build with Clang.
Notes
Notes: svn path=/head/; revision=278311
Diffstat (limited to 'audio/oss')
-rw-r--r--audio/oss/Makefile2
-rw-r--r--audio/oss/files/patch-setup-FreeBSD-build.sh38
2 files changed, 40 insertions, 0 deletions
diff --git a/audio/oss/Makefile b/audio/oss/Makefile
index 7350f0f0b236..5bd72bf30736 100644
--- a/audio/oss/Makefile
+++ b/audio/oss/Makefile
@@ -63,6 +63,8 @@ IGNORE= requires kernel source to be installed
.include <bsd.port.pre.mk>
+CONFIGURE_ENV+= HOSTCC="${CC}"
+
.if !defined(WITHOUT_VORBIS)
LIB_DEPENDS+= vorbisfile.6:${PORTSDIR}/audio/libvorbis
CONFIGURE_ENV+= OGG_SUPPORT=YES
diff --git a/audio/oss/files/patch-setup-FreeBSD-build.sh b/audio/oss/files/patch-setup-FreeBSD-build.sh
new file mode 100644
index 000000000000..40eb0ed30a1b
--- /dev/null
+++ b/audio/oss/files/patch-setup-FreeBSD-build.sh
@@ -0,0 +1,38 @@
+--- setup/FreeBSD/build.sh.orig 2011-01-04 20:33:08.000000000 -0500
++++ setup/FreeBSD/build.sh 2011-07-25 13:39:05.000000000 -0400
+@@ -7,7 +7,7 @@
+ TXT2MAN=$SRCDIR/setup/txt2man
+ else
+ echo "No gawk found. Using lesser replacement" >&2
+- cc -o txt2man origdir/setup/txt2man.c
++ $CC -o txt2man origdir/setup/txt2man.c
+ TXT2MAN=./txt2man
+ fi
+
+@@ -38,7 +38,7 @@
+
+ # Regenerating the config file templates
+ rm -f /tmp/confgen
+-if ! cc -o /tmp/confgen ./setup/FreeBSD/confgen.c
++if ! $CC -o /tmp/confgen ./setup/FreeBSD/confgen.c
+ then
+ echo Building confgen failed
+ exit 1
+@@ -146,7 +146,7 @@
+ # Licensing stuff
+ if test -f $SRCDIR/4front-private/osslic.c
+ then
+- cc -o prototype/usr/sbin/osslic -Isetup -Ikernel/nonfree/include -Ikernel/framework/include -Iinclude -Ikernel/OS/FreeBSD -I$SRCDIR $SRCDIR/4front-private/osslic.c
++ $CC -o prototype/usr/sbin/osslic -Isetup -Ikernel/nonfree/include -Ikernel/framework/include -Iinclude -Ikernel/OS/FreeBSD -I$SRCDIR $SRCDIR/4front-private/osslic.c
+ strip prototype/usr/sbin/osslic
+
+ BITS=3 # Default to 32 bit ELF format
+@@ -162,7 +162,7 @@
+ if test -f 4front-private/ossupdate.c
+ then
+ #ossupdate
+- cc -I. 4front-private/ossupdate.c -s -o prototype/usr/sbin/ossupdate
++ $CC -I. 4front-private/ossupdate.c -s -o prototype/usr/sbin/ossupdate
+ fi
+
+ sh $SRCDIR/setup/build_common.sh $SRCDIR $OSSLIBDIR