aboutsummaryrefslogtreecommitdiff
path: root/audio/pacpl/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-06-17 19:26:01 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-06-17 19:26:01 +0000
commit2c0279d8500526d4008993580efb783946f2a7ea (patch)
tree29b5e0c73734c09830d347abf4d9d3311fbf9f22 /audio/pacpl/Makefile
parentfdef6b0ea81976c25b4de8374f3ffdc326947dc2 (diff)
downloadports-2c0279d8500526d4008993580efb783946f2a7ea.tar.gz
ports-2c0279d8500526d4008993580efb783946f2a7ea.zip
Update to 4.05
PR: ports/135605 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=236155
Diffstat (limited to 'audio/pacpl/Makefile')
-rw-r--r--audio/pacpl/Makefile104
1 files changed, 25 insertions, 79 deletions
diff --git a/audio/pacpl/Makefile b/audio/pacpl/Makefile
index 39ee5d1dab14..15b15d3cfaa8 100644
--- a/audio/pacpl/Makefile
+++ b/audio/pacpl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pacpl
-PORTVERSION= 4.0.3
+PORTVERSION= 4.0.5
CATEGORIES= audio
MASTER_SITES= SFE
@@ -49,14 +49,30 @@ OPTIONS= BLADEENC "BladeEnc support" off \
TTA "TTA support" off \
WAVPACK "WavPack support" off \
WMATAG "WMA Tagging support" off \
- KONQUEROR "KDE/Konqueror integration" off \
- DOLPHIN "Dolphin integration" off \
- AMAROK "Amarok integration" off \
+ KDE4SM "Konqueror/Dolphin integration" off \
+ AMAROK "Amarok integration (BROKEN)" off \
MORELANGS "Additional language support" off
MAN1= pacpl.1
PACPL_PO= en_US.po
+.include <bsd.port.options.mk>
+
+.if defined(WITH_KDE4SM)
+USE_KDE4= kdebase
+PLIST_SUB+= KDE4SERVICEMENU="" KDE4_PREFIX="${KDE4_PREFIX}"
+.else
+PLIST_SUB+= KDE4SERVICEMENU="@comment "
+.endif
+
+.if defined(WITH_AMAROK)
+BROKEN= Amarok support temporarily broken in 4.05+
+RUN_DEPENDS+= amarok:${PORTSDIR}/audio/amarok
+PLIST_SUB+= AMAROK=""
+.else
+PLIST_SUB+= AMAROK="@comment "
+.endif
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500701
@@ -69,10 +85,6 @@ RUN_DEPENDS+= bladeenc:${PORTSDIR}/audio/bladeenc
.if defined(WITH_BONK)
RUN_DEPENDS+= bonk:${PORTSDIR}/audio/bonk
-KONQMIMES+= x-bonk
-PLIST_SUB+= BONK=""
-.else
-PLIST_SUB+= BONK="@comment "
.endif
.if defined(WITH_CDDB)
@@ -113,10 +125,6 @@ RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
.if defined(WITH_LAUDIO)
RUN_DEPENDS+= laudio:${PORTSDIR}/audio/laudio
-KONQMIMES+= x-la
-PLIST_SUB+= LAUDIO=""
-.else
-PLIST_SUB+= LAUDIO="@comment "
.endif
.if defined(WITH_SNDFILE)
@@ -125,18 +133,10 @@ RUN_DEPENDS+= sndfile-convert:${PORTSDIR}/audio/libsndfile
.if defined(WITH_LPAC)
RUN_DEPENDS+= lpac:${PORTSDIR}/audio/lpac
-KONQMIMES+= x-lpac
-PLIST_SUB+= LPAC=""
-.else
-PLIST_SUB+= LPAC="@comment "
.endif
.if defined(WITH_MONKEY)
RUN_DEPENDS+= mac:${PORTSDIR}/audio/mac
-KONQMIMES+= x-ape
-PLIST_SUB+= MONKEY=""
-.else
-PLIST_SUB+= MONKEY="@comment "
.endif
.if defined(WITH_MUSETAG) || defined(WITH_APETAG)
@@ -161,10 +161,6 @@ RUN_DEPENDS+= mppenc:${PORTSDIR}/audio/musepack
.if defined(WITH_OPTIMFROG)
RUN_DEPENDS+= ofr:${PORTSDIR}/audio/optimfrog
-KONQMIMES+= x-ofr x-ofs
-PLIST_SUB+= OPTIMFROG=""
-.else
-PLIST_SUB+= OPTIMFROG="@comment "
.endif
.if defined(WITH_OGGVORBIS)
@@ -177,10 +173,6 @@ RUN_DEPENDS+= p5-Ogg-Vorbis-Header>0:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header
.if defined(WITH_SHORTEN)
RUN_DEPENDS+= shorten:${PORTSDIR}/audio/shorten
-KONQMIMES+= x-shn
-PLIST_SUB+= SHORTEN=""
-.else
-PLIST_SUB+= SHORTEN="@comment "
.endif
.if defined(WITH_SOX)
@@ -197,54 +189,18 @@ RUN_DEPENDS+= toolame:${PORTSDIR}/audio/toolame
.if defined(WITH_TTA)
RUN_DEPENDS+= ttaenc:${PORTSDIR}/audio/tta
-KONQMIMES+= x-tta
-PLIST_SUB+= TTA=""
-.else
-PLIST_SUB+= TTA="@comment "
.endif
.if defined(WITH_WAVPACK)
RUN_DEPENDS+= wavpack:${PORTSDIR}/audio/wavpack
-KONQMIMES+= x-wavpack
-PLIST_SUB+= WAVPACK=""
-.else
-PLIST_SUB+= WAVPACK="@comment "
.endif
.if defined(WITH_WMATAG)
RUN_DEPENDS+= p5-Audio-WMA>0:${PORTSDIR}/audio/p5-Audio-WMA
.endif
-.if defined(WITH_FFMPEG) && defined(WITH_MPLAYER)
-KONQMIMES+= x-rm
-PLIST_SUB+= RM=""
-.else
-PLIST_SUB+= RM="@comment "
-.endif
-
-.if defined(WITH_KONQUEROR)
-RUN_DEPENDS+= konqueror:${PORTSDIR}/x11/kdebase3
-PLIST_SUB+= KONQUEROR=""
-.else
-PLIST_SUB+= KONQUEROR="@comment "
-.endif
-
-.if defined(WITH_AMAROK)
-RUN_DEPENDS+= amarok:${PORTSDIR}/audio/amarok
-PLIST_SUB+= AMAROK=""
-.else
-PLIST_SUB+= AMAROK="@comment "
-.endif
-
-.if defined(WITH_DOLPHIN)
-RUN_DEPENDS+= dolphin:${PORTSDIR}/x11-fm/dolphin
-PLIST_SUB+= DOLPHIN=""
-.else
-PLIST_SUB+= DOLPHIN="@comment "
-.endif
-
.if defined(WITH_MORELANGS)
-PACPL_PO+= ca.po de.po es.po et.po fr_FR.po pl.po pt.po ru_RU.po tr.po zh_CN.po
+PACPL_PO+= ca.po de.po es.po et.po fr_FR.po it_IT.po nl_NL.po pl.po pt.po ro.po ru_RU.po tr.po zh_CN.po
PLIST_SUB+= ADDITIONAL_LANGS=""
.else
PLIST_SUB+= ADDITIONAL_LANGS="@comment "
@@ -255,8 +211,8 @@ post-extract:
@${ECHO_MSG} ""
@${ECHO_MSG} " * * * * * * * * * W A R N I N G * * * * * * * * * * * * * "
@${ECHO_MSG} ""
- @${ECHO_MSG} "WARNING: Integration options with Amarok, Dolphin, and"
- @${ECHO_MSG} "KDE3/Konqueror now pull in their respective ports!"
+ @${ECHO_MSG} "WARNING: Integration options with Amarok, KDE4 Dolphin and"
+ @${ECHO_MSG} "Konqueror now pull in their respective ports!"
@${ECHO_MSG} ""
@${ECHO_MSG} "The port now provides the option to select codecs, CD"
@${ECHO_MSG} "burning, CDDB and tagging modules individually so you don't"
@@ -291,13 +247,8 @@ do-install:
@pod2man ${WRKSRC}/pacpl ${WRKSRC}/pacpl.1
${INSTALL_MAN} ${WRKSRC}/pacpl.1 ${MAN1PREFIX}/man/man1/
-.if defined(WITH_KONQUEROR)
- ${MKDIR} ${PREFIX}/share/mimelnk/audio
- ${MKDIR} ${PREFIX}/share/apps/konqueror/servicemenus
- ${INSTALL_DATA} ${WRKSRC}/plugins/konqueror/pacpl.desktop ${PREFIX}/share/apps/konqueror/servicemenus/
-.for m in ${KONQMIMES}
- ${INSTALL_DATA} ${WRKSRC}/plugins/konqueror/mimes/${m}.desktop ${PREFIX}/share/mimelnk/audio/
-.endfor
+.if defined(WITH_KDE4SM)
+ ${INSTALL_DATA} ${WRKSRC}/plugins/konqueror/pacpl.desktop ${KDE4_PREFIX}/share/kde4/services/ServiceMenus
.endif
.if defined(WITH_AMAROK)
@@ -306,11 +257,6 @@ do-install:
${PERL} -e 'print qq(name = Pacx\ntype = transcode)' > ${PREFIX}/share/apps/amarok/scripts/transcoding_pacx/transcoding_pacx.spec
.endif
-.if defined(WITH_DOLPHIN)
- ${MKDIR} ${PREFIX}/share/apps/dolphin/servicemenus
- ${INSTALL_DATA} ${WRKSRC}/plugins/dolphin/pacpl.desktop ${PREFIX}/share/apps/dolphin/servicemenus/
-.endif
-
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/extra/README.module ${WRKSRC}/ChangeLog ${WRKSRC}/README ${DOCSDIR}