aboutsummaryrefslogtreecommitdiff
path: root/audio/pianobooster
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-12-15 05:48:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-12-15 05:48:18 +0000
commit1b3c545d92e37509a61aaa263e2905a4b7402fa8 (patch)
tree67f3d5f53195f9ada2f81e2b148ae371e7717038 /audio/pianobooster
parent43b7be6113d942777459339371b3a786cabb895f (diff)
downloadports-1b3c545d92e37509a61aaa263e2905a4b7402fa8.tar.gz
ports-1b3c545d92e37509a61aaa263e2905a4b7402fa8.zip
audio/pianobooster: Update 0.7.2b -> 1.0.0
Reported by: portscout
Notes
Notes: svn path=/head/; revision=558137
Diffstat (limited to 'audio/pianobooster')
-rw-r--r--audio/pianobooster/Makefile5
-rw-r--r--audio/pianobooster/distinfo6
-rw-r--r--audio/pianobooster/files/patch-src_MidiDevice.cpp22
-rw-r--r--audio/pianobooster/files/patch-src_MidiDeviceFluidSynth.cpp33
-rw-r--r--audio/pianobooster/pkg-descr2
-rw-r--r--audio/pianobooster/pkg-plist2
6 files changed, 7 insertions, 63 deletions
diff --git a/audio/pianobooster/Makefile b/audio/pianobooster/Makefile
index 663c0cae4ba9..a881ebd01c3a 100644
--- a/audio/pianobooster/Makefile
+++ b/audio/pianobooster/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pianobooster
DISTVERSIONPREFIX= v
-DISTVERSION= 0.7.2b
+DISTVERSION= 1.0.0
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
@@ -22,7 +22,8 @@ GH_PROJECT= PianoBooster
USE_QT= core gui opengl widgets xml buildtools_build linguisttools_build qmake_build
USE_GL= gl glu
-CMAKE_ON= USE_SYSTEM_RTMIDI USE_JACK
+CMAKE_ON= USE_JACK
+CMAKE_OFF= USE_BUNDLED_RTMIDI
CMAKE_ARGS= -DDATA_DIR:STRING=share/${PORTNAME}
OPTIONS_DEFINE= FLUIDSYNTH
diff --git a/audio/pianobooster/distinfo b/audio/pianobooster/distinfo
index f7bef0750554..cc8e4b6d6e95 100644
--- a/audio/pianobooster/distinfo
+++ b/audio/pianobooster/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1586862081
-SHA256 (captnfab-PianoBooster-v0.7.2b_GH0.tar.gz) = fe331f9bebafda31444fa415a6594a91f8283ba9c3cf18066684072081490633
-SIZE (captnfab-PianoBooster-v0.7.2b_GH0.tar.gz) = 2542590
+TIMESTAMP = 1608008248
+SHA256 (captnfab-PianoBooster-v1.0.0_GH0.tar.gz) = 1b58e9587c9bcc180d28c5a3701f0131bf8ac96edeaace7e32d8c8010e9ce1b6
+SIZE (captnfab-PianoBooster-v1.0.0_GH0.tar.gz) = 3096142
diff --git a/audio/pianobooster/files/patch-src_MidiDevice.cpp b/audio/pianobooster/files/patch-src_MidiDevice.cpp
deleted file mode 100644
index b511dbe2fa67..000000000000
--- a/audio/pianobooster/files/patch-src_MidiDevice.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/MidiDevice.cpp.orig 2020-02-25 07:45:06 UTC
-+++ src/MidiDevice.cpp
-@@ -32,9 +32,9 @@
- #include "MidiDeviceFluidSynth.h"
- #endif
-
-+#include <QDebug>
-
-
--
- CMidiDevice::CMidiDevice()
- {
- m_rtMidiDevice = new CMidiDeviceRt();
-@@ -65,6 +65,8 @@ QStringList CMidiDevice::getMidiPortList(midiType_t ty
- QStringList list;
- #if EXPERIMENTAL_USE_FLUIDSYNTH
- list << m_fluidSynthMidiDevice->getMidiPortList(type);
-+ if (list.empty())
-+ qWarning() << "FluidSynth midi device didn't return any midi ports of midi type=" << type;
- #endif
- list << m_rtMidiDevice->getMidiPortList(type);
-
diff --git a/audio/pianobooster/files/patch-src_MidiDeviceFluidSynth.cpp b/audio/pianobooster/files/patch-src_MidiDeviceFluidSynth.cpp
deleted file mode 100644
index 40ca4243225a..000000000000
--- a/audio/pianobooster/files/patch-src_MidiDeviceFluidSynth.cpp
+++ /dev/null
@@ -1,33 +0,0 @@
---- src/MidiDeviceFluidSynth.cpp.orig 2019-07-09 08:30:16 UTC
-+++ src/MidiDeviceFluidSynth.cpp
-@@ -30,6 +30,7 @@
-
- #include <QString>
- #include <QDir>
-+#include <QDebug>
- #include <string>
-
- CMidiDeviceFluidSynth::CMidiDeviceFluidSynth()
-@@ -54,7 +55,7 @@ void CMidiDeviceFluidSynth::init()
-
- QStringList CMidiDeviceFluidSynth::getMidiPortList(midiType_t type)
- {
--
-+ qInfo() << "YURI CMidiDeviceFluidSynth::getMidiPortList type=" << type << " MIDI_OUTPUT=" << MIDI_OUTPUT;
- if (type != MIDI_OUTPUT) // Only has an output
- return QStringList();
-
-@@ -62,11 +63,13 @@ QStringList CMidiDeviceFluidSynth::getMidiPortList(mid
- QDir dirSoundFont("soundfont");
- dirSoundFont.setFilter(QDir::Files);
- QStringList fileNames = dirSoundFont.entryList();
-+ qInfo() << "YURI CMidiDeviceFluidSynth::getMidiPortList numFileNames=" << fileNames.size() << " in dir=" << dirSoundFont;
-
- QStringList portNames;
-
- for (int i = 0; i < fileNames.size(); i++)
- {
-+ qInfo() << "YURI CMidiDeviceFluidSynth::getMidiPortList file[" << i << "]=" << fileNames.at(i);
- if ( fileNames.at(i).endsWith(".sf2", Qt::CaseInsensitive ) )
- {
- portNames += fileNames.at(i);
diff --git a/audio/pianobooster/pkg-descr b/audio/pianobooster/pkg-descr
index c933afda9813..47e737dda61e 100644
--- a/audio/pianobooster/pkg-descr
+++ b/audio/pianobooster/pkg-descr
@@ -3,4 +3,4 @@ allows you to change the speed of playback and transpose the music etc.
There is a scrolling musical stave that shows the notes for just one part
from all the parts in the complete musical arrangement.
-WWW: http://pianobooster.sourceforge.net
+WWW: https://www.pianobooster.org/index.html
diff --git a/audio/pianobooster/pkg-plist b/audio/pianobooster/pkg-plist
index 21c64fbd2999..61e9e4754d9a 100644
--- a/audio/pianobooster/pkg-plist
+++ b/audio/pianobooster/pkg-plist
@@ -6,8 +6,6 @@ share/icons/hicolor/64x64/apps/pianobooster.png
%%DATADIR%%/fonts/DejaVuSans.ttf
%%DATADIR%%/music/BoosterMusicBooks.zip
%%DATADIR%%/translations/langs.json
-%%DATADIR%%/translations/music_ru.qm
-%%DATADIR%%/translations/music_uk.qm
%%DATADIR%%/translations/pianobooster_ca.qm
%%DATADIR%%/translations/pianobooster_cs.qm
%%DATADIR%%/translations/pianobooster_da.qm