aboutsummaryrefslogtreecommitdiff
path: root/audio/play/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-19 14:23:18 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-19 14:23:18 +0000
commit8004b3f80725ee0b30305914c1649060da783f6e (patch)
treed8f2edb8c58452fd03c2506163d7a712fa76247c /audio/play/Makefile
parentdecfe46d606ac13de38e5bc26e219013227638e8 (diff)
downloadports-8004b3f80725ee0b30305914c1649060da783f6e.tar.gz
ports-8004b3f80725ee0b30305914c1649060da783f6e.zip
Use MAKE_ARGS & REINPLACE
Notes
Notes: svn path=/head/; revision=133672
Diffstat (limited to 'audio/play/Makefile')
-rw-r--r--audio/play/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/audio/play/Makefile b/audio/play/Makefile
index 826039a0c435..60944593e149 100644
--- a/audio/play/Makefile
+++ b/audio/play/Makefile
@@ -14,7 +14,10 @@ MASTER_SITES= ${MASTER_SITE_PORTS_JP}
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple audio file player
-CONFLICTS= sox-*
+CONFLICTS= sox-[0-9]*
+
+USE_REINPLACE= yes
+MAKE_ARGS= CFLAGS="${CFLAGS}" DESTDIR="${PREFIX}" MANDIR="/man/ja/man"
MANLANG= ja
MAN1= play.1
@@ -23,10 +26,7 @@ PLIST_FILES= bin/play
post-patch:
.for file in play_audio.c mixer_ctl.c encode_sun.c encode_riff.c speed.c
- @${CHMOD} u+w ${WRKSRC}/${file}
- @${SED} 's,machine/soundcard.h,sys/soundcard.h,' < ${WRKSRC}/${file} \
- > ${WRKSRC}/${file}.new
- @${MV} ${WRKSRC}/${file}.new ${WRKSRC}/${file}
+ @${REINPLACE_CMD} 's,machine/soundcard.h,sys/soundcard.h,' ${WRKSRC}/${file}
.endfor
.include <bsd.port.mk>