aboutsummaryrefslogtreecommitdiff
path: root/audio/portmidi/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-07-17 02:31:07 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-07-17 02:31:07 +0000
commit4efef974205a73ebe689bd11db595e7ef3f23437 (patch)
tree09658c735ce1285e8e079cee660be85ca6b303b5 /audio/portmidi/Makefile
parentd902630dfc4c9cc00cb97b7813f52ca0856acb0e (diff)
downloadports-4efef974205a73ebe689bd11db595e7ef3f23437.tar.gz
ports-4efef974205a73ebe689bd11db595e7ef3f23437.zip
audio/portmidi: New port: Library for real time MIDI input and output
PortMIDI is a cross platform (Windows, macOS, Linux, and BSDs which support alsalib) library for interfacing with operating systems' MIDI I/O APIs. It was started by Ross Bencina and Phil Burk, then maintained by Roger B. Dannenberg, and now maintained by the Mixxx DJ Software team. WWW: https://github.com/mixxxdj/portmidi
Diffstat (limited to 'audio/portmidi/Makefile')
-rw-r--r--audio/portmidi/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/audio/portmidi/Makefile b/audio/portmidi/Makefile
new file mode 100644
index 000000000000..e3f859e0061d
--- /dev/null
+++ b/audio/portmidi/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= portmidi
+PORTVERSION= 235.0
+CATEGORIES= audio
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Library for real time MIDI input and output
+
+LICENSE= PL
+LICENSE_NAME= PortMidi license
+LICENSE_FILE= ${WRKSRC}/license.txt
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+LIB_DEPENDS= libasound.so:audio/alsa-lib
+
+USES= cmake dos2unix localbase:ldflags
+
+USE_GITHUB= yes
+GH_ACCOUNT= mixxxdj
+
+.include <bsd.port.mk>