aboutsummaryrefslogtreecommitdiff
path: root/audio/praat/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-27 22:44:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-27 22:44:20 +0000
commitb4b4aecee16a48da69d927487a0bc33033d6574c (patch)
tree780ca9948585ee44a6572a47349c11f3ad2e2a58 /audio/praat/Makefile
parent0d93374ffdb4a99a6f6aacceb129a7e4b3b49151 (diff)
downloadports-b4b4aecee16a48da69d927487a0bc33033d6574c.tar.gz
ports-b4b4aecee16a48da69d927487a0bc33033d6574c.zip
- Update to 4.6.39
PR: 118383 Submitted by: Sven Petai <hadara@bsd.ee> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=204634
Diffstat (limited to 'audio/praat/Makefile')
-rw-r--r--audio/praat/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/audio/praat/Makefile b/audio/praat/Makefile
index ee3d179201e4..8ceb5b4826b5 100644
--- a/audio/praat/Makefile
+++ b/audio/praat/Makefile
@@ -6,22 +6,27 @@
#
PORTNAME= praat
-PORTVERSION= 4.4.10
-PORTREVISION= 1
+PORTVERSION= 4.6.39
CATEGORIES= audio science
-MASTER_SITES= http://www.neuro.mcw.edu/~bacon/Ports/distfiles/Praat/4410/
-DISTNAME= praat4410_sources
+MASTER_SITES= http://www.neuro.mcw.edu/~bacon/Ports/distfiles/Praat/4639/ \
+ http://www.fon.hum.uva.nl/praat/
+DISTNAME= praat4639_sources
MAINTAINER= bacon@smithers.neuro.mcw.edu
COMMENT= Phonetics by Computer
-USE_X_PREFIX= yes
+USE_DOS2UNIX= yes
+DOS2UNIX_REGEX= .*Makefile
+USE_XLIB= yes
USE_MOTIF= yes
-WRKSRC= ${WRKDIR}/sources_4410
+WRKSRC= ${WRKDIR}/sources_4639
MAKEFILE= makefile
PLIST_FILES= bin/praat
+MAN1= praat.1
+
post-patch:
+ @${REINPLACE_CMD} -e 's/ log2/ NUMlog2/' ${WRKSRC}/dwtools/Sound_extensions.c
@${FIND} ${WRKSRC} -name Makefile -exec \
${REINPLACE_CMD} -e 's|^CFLAGS =|CFLAGS +=|' "{}" \;
@${CP} ${WRKSRC}/makefiles/makefile.defs.freebsd.dynamic \
@@ -29,5 +34,6 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/praat ${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/praat.1 ${PREFIX}/man/man1
.include <bsd.port.mk>