aboutsummaryrefslogtreecommitdiff
path: root/audio/py-al/Makefile
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-04-26 15:57:02 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-04-26 15:57:02 +0000
commit3a44eb599e2d9d9be082e19d71169c71733edf8e (patch)
tree4b54f46bd2c285526f5ae930c5379f4bbc17d1e1 /audio/py-al/Makefile
parent9dbc02d2c5d8b2c2c499e0e86015bc9505c69318 (diff)
downloadports-3a44eb599e2d9d9be082e19d71169c71733edf8e.tar.gz
ports-3a44eb599e2d9d9be082e19d71169c71733edf8e.zip
PyAL is a wrapper around the OpenAL library and as such similar to the
discontinued PyOpenAL project. In contrast to PyOpenAL, it has no licensing restrictions, nor does it rely on C code, but uses ctypes instead. WWW: http://bitbucket.org/marcusva/py-al
Notes
Notes: svn path=/head/; revision=316621
Diffstat (limited to 'audio/py-al/Makefile')
-rw-r--r--audio/py-al/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/audio/py-al/Makefile b/audio/py-al/Makefile
new file mode 100644
index 000000000000..9b1222d6c8dc
--- /dev/null
+++ b/audio/py-al/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= al
+PORTVERSION= 0.1.0
+CATEGORIES= audio python
+MASTER_SITES= http://cdn.bitbucket.org/marcusva/py-al/downloads/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyAL-${PORTVERSION}
+
+MAINTAINER= mva@FreeBSD.org
+COMMENT= PyAL is a binding of OpenAL for Python
+
+USE_OPENAL= al
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= PyAL
+
+.include <bsd.port.mk>