aboutsummaryrefslogtreecommitdiff
path: root/audio/py-pocketsphinx/Makefile
diff options
context:
space:
mode:
authorJesús Daniel Colmenares Oviedo <DtxdF@disroot.org>2022-09-23 19:03:34 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2022-10-25 19:16:28 +0000
commit74c7ab2091f110961bf4f7a4829c56ff7c75bdba (patch)
tree149939519653c9f74f772ca5c23b63687fd9f525 /audio/py-pocketsphinx/Makefile
parent77c1fcfb394700288d816bfc957fcac82a72973d (diff)
downloadports-74c7ab2091f110961bf4f7a4829c56ff7c75bdba.tar.gz
ports-74c7ab2091f110961bf4f7a4829c56ff7c75bdba.zip
Add audio/py-pocketsphinx: Python interface to CMU Sphinxbase and Pocketsphinx libraries
Pocketsphinx is a part of the CMU Sphinx Open Source Toolkit For Speech Recognition. This package provides a python interface to CMU Sphinxbase and Pocketsphinx libraries created with SWIG and Setuptools. WWW: https://github.com/bambocher/pocketsphinx-python PR: 265766
Diffstat (limited to 'audio/py-pocketsphinx/Makefile')
-rw-r--r--audio/py-pocketsphinx/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/py-pocketsphinx/Makefile b/audio/py-pocketsphinx/Makefile
new file mode 100644
index 000000000000..be33992ba3d2
--- /dev/null
+++ b/audio/py-pocketsphinx/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= pocketsphinx
+PORTVERSION= 0.1.15
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= DtxdF@disroot.org
+COMMENT= Python interface to CMU Sphinxbase and Pocketsphinx libraries
+WWW= https://github.com/bambocher/pocketsphinx-python
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= swig>0:devel/swig
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libpulse-simple.so:audio/pulseaudio \
+ libpulse.so:audio/pulseaudio
+
+USES= python:3.8+
+USE_PYTHON= distutils
+
+CFLAGS+= -I${LOCALBASE}/include
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/pocketsphinx/_pocketsphinx${PYTHON_EXT_SUFFIX}.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/sphinxbase/_ad_alsa${PYTHON_EXT_SUFFIX}.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/sphinxbase/_ad_pulse${PYTHON_EXT_SUFFIX}.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/sphinxbase/_sphinxbase${PYTHON_EXT_SUFFIX}.so
+
+.include <bsd.port.mk>