aboutsummaryrefslogtreecommitdiff
path: root/audio/q-audio/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-04-11 19:22:28 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-04-11 19:22:28 +0000
commitb660c64cd30af38231fe6c70127dabdc152cc7e1 (patch)
tree0f93d13c2b80c049cde9eda00372932afffb0356 /audio/q-audio/Makefile
parent07a87aeb97cb1e8951bd39474f8482e89dfb3ac7 (diff)
downloadports-b660c64cd30af38231fe6c70127dabdc152cc7e1.tar.gz
ports-b660c64cd30af38231fe6c70127dabdc152cc7e1.zip
- Update to 2.7
- UnDEPRECATE and UnEXPIRE after resurrection of lang/q - Take maintainship
Notes
Notes: svn path=/head/; revision=232112
Diffstat (limited to 'audio/q-audio/Makefile')
-rw-r--r--audio/q-audio/Makefile35
1 files changed, 13 insertions, 22 deletions
diff --git a/audio/q-audio/Makefile b/audio/q-audio/Makefile
index aeb106399147..f5471560e7c6 100644
--- a/audio/q-audio/Makefile
+++ b/audio/q-audio/Makefile
@@ -6,36 +6,27 @@
#
PORTNAME= audio
-PORTVERSION= 1.2
-PORTREVISION= 5
+PORTVERSION= 2.7
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= q-lang
+MASTER_SITES= SF/q-lang
PKGNAMEPREFIX= q-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= Q-Audio -- digital audio interface for the Q language
-LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
- q.6:${PORTSDIR}/lang/q
-
-DEPRECATED= depends on deprecated port lang/q
-EXPIRATION_DATE= 2008-12-24
-
-USE_GNOME= gnometarget
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-pthread="${PTHREAD_LIBS}"
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+LIB_DEPENDS= q.8:${PORTSDIR}/lang/q \
+ jack.0:${PORTSDIR}/audio/jack \
+ samplerate.1:${PORTSDIR}/audio/libsamplerate \
+ fftw3.4:${PORTSDIR}/math/fftw3
+BUILD_DEPENDS= ${LOCALBASE}/lib/portaudio2/libportaudio.so.2:${PORTSDIR}/audio/portaudio2
+RUN_DEPENDS= ${BUILD_DEPENDS}
DATADIR= ${PREFIX}/share/q
-EXAMPLESDIR= ${PREFIX}/share/examples/q/audio
-post-patch:
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
- ${GREP} -l "^examplesdir" | ${XARGS} ${REINPLACE_CMD} -e \
- "s;[(]pkgdatadir[)]/examples;(datadir)/examples/q;"
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+CFLAGS+= -I${LOCALBASE}/include/portaudio2 -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib/portaudio2 -L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
.include <bsd.port.mk>