aboutsummaryrefslogtreecommitdiff
path: root/audio/qsynth
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-11-21 15:55:58 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-11-21 15:55:58 +0000
commit189e88416ed0fd619fd4a9b10e5f98bed35f7eed (patch)
treeb07108f3845f972bf7816437710ce8cc27f4c815 /audio/qsynth
parent4ddfac46e6a05a37eb2f933c653d844fe9a813a8 (diff)
downloadports-189e88416ed0fd619fd4a9b10e5f98bed35f7eed.tar.gz
ports-189e88416ed0fd619fd4a9b10e5f98bed35f7eed.zip
- Get rid of QMAKEFLAGS
- Use options helpers - Use globally provided LRELEASE/LUPDATE - Convert LIB_DEPENDS to new style
Notes
Notes: svn path=/head/; revision=334498
Diffstat (limited to 'audio/qsynth')
-rw-r--r--audio/qsynth/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/audio/qsynth/Makefile b/audio/qsynth/Makefile
index 75a312e69052..41b5de6f4714 100644
--- a/audio/qsynth/Makefile
+++ b/audio/qsynth/Makefile
@@ -15,8 +15,12 @@ LIB_DEPENDS= fluidsynth:${PORTSDIR}/audio/fluidsynth
OPTIONS_DEFINE= GRADIENT SYSTEM_TRAY
OPTIONS_DEFAULT= GRADIENT SYSTEM_TRAY
+
GRADIENT_DESC= Gradient eye-candy
+GRADIENT_CONFIGURE_OFF= --disable-gradient
+
SYSTEM_TRAY_DESC= System-tray icon
+SYSTEM_TRAY_CONFIGURE_OFF= --disable-system-tray
USE_QT4= gui linguist_build moc_build qmake_build rcc_build uic_build
NO_STAGE= yes
@@ -26,26 +30,16 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_ac_moc=${MOC} \
ac_cv_path_ac_uic=${UIC} \
ac_cv_path_ac_qmake=${QMAKE} \
- ac_cv_path_ac_lupdate=${LOCALBASE}/bin/lupdate-qt4 \
- ac_cv_path_ac_lrelease=${LOCALBASE}/bin/lrelease-qt4
+ ac_cv_path_ac_lupdate=${LUPDATE} \
+ ac_cv_path_ac_lrelease=${LRELEASE}
CONFIGURE_ARGS= --localedir=${DATADIR} \
--with-qt=${QT_PREFIX} \
--with-fluidsynth=${LOCALBASE}
INSTALLS_ICONS= yes
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MGRADIENT)
-CONFIGURE_ARGS+=--disable-gradient
-.endif
-
-.if empty(PORT_OPTIONS:MSYSTEM_TRAY)
-CONFIGURE_ARGS+=--disable-system-tray
-.endif
-
post-configure:
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -o qsynth.mak \
- ${QMAKEFLAGS})
+ ${QMAKE_ARGS})
post-install:
@${STRIP_CMD} ${PREFIX}/bin/qsynth