aboutsummaryrefslogtreecommitdiff
path: root/audio/qsynth
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-03-12 05:09:00 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-03-12 05:09:00 +0000
commit626c4a03609f6a9e543f27edb2a241fbae7485c1 (patch)
treea114a5603117967fe90e686e53a2c3d19bef669a /audio/qsynth
parentbe2a73f1e55a8b0c34118ab4ee91ad62c546cd4d (diff)
downloadports-626c4a03609f6a9e543f27edb2a241fbae7485c1.tar.gz
ports-626c4a03609f6a9e543f27edb2a241fbae7485c1.zip
audio/qsynth: Cosmetic changes
Notes
Notes: svn path=/head/; revision=495433
Diffstat (limited to 'audio/qsynth')
-rw-r--r--audio/qsynth/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/audio/qsynth/Makefile b/audio/qsynth/Makefile
index c511693fad0b..8188b2fe5bbd 100644
--- a/audio/qsynth/Makefile
+++ b/audio/qsynth/Makefile
@@ -17,30 +17,32 @@ LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
USES= compiler:c++11-lang gmake pkgconfig qt:5
USE_CXXSTD= c++11
-USE_QT= core gui widgets x11extras buildtools_build linguisttools_build qmake_build
+USE_QT= core gui widgets x11extras buildtools_build linguisttools_build \
+ qmake_build
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_ac_cv_qmake=${QMAKE} \
- ac_cv_path_ac_moc=${MOC} \
- ac_cv_path_ac_uic=${UIC} \
+ ac_cv_path_ac_lrelease=${LRELEASE} \
ac_cv_path_ac_lupdate=${LUPDATE} \
- ac_cv_path_ac_lrelease=${LRELEASE}
+ ac_cv_path_ac_moc=${MOC} \
+ ac_cv_path_ac_uic=${UIC}
CONFIGURE_ARGS= --localedir=${DATADIR} \
--with-fluidsynth=${LOCALBASE}
-LDFLAGS+= -Wl,--as-needed # cf. PR 224488
+# cf. PR 224488
+LDFLAGS+= -Wl,--as-needed
-OPTIONS_DEFINE= GRADIENT SYSTEM_TRAY XUNIQUE
+OPTIONS_DEFINE= GRADIENT SYSTEM_TRAY XUNIQUE
OPTIONS_DEFAULT= GRADIENT SYSTEM_TRAY XUNIQUE
-GRADIENT_DESC= Gradient eye-candy
+GRADIENT_DESC= Gradient eye-candy
SYSTEM_TRAY_DESC= System-tray icon support
-XUNIQUE_DESC= X11 unique/single instance
+XUNIQUE_DESC= X11 unique/single instance
GRADIENT_CONFIGURE_ENABLE= gradient
SYSTEM_TRAY_CONFIGURE_ENABLE= system-tray
XUNIQUE_CONFIGURE_ENABLE= xunique
-XUNIQUE_USE= XORG=x11
+XUNIQUE_USE= XORG=x11
post-patch:
@${REINPLACE_CMD} -e ' \