aboutsummaryrefslogtreecommitdiff
path: root/audio/qsynth
diff options
context:
space:
mode:
authorArmin Pirkovitsch <sperber@FreeBSD.org>2012-11-30 23:51:30 +0000
committerArmin Pirkovitsch <sperber@FreeBSD.org>2012-11-30 23:51:30 +0000
commit62c72040c78dfa303a4d0a8ec94eab76397f564c (patch)
tree30c72f7a1cdf7d7c6b4d3f602a3d5155f2156e19 /audio/qsynth
parent3fb43a1b5fd75df8ef026d9c56711b28c4503801 (diff)
downloadports-62c72040c78dfa303a4d0a8ec94eab76397f564c.tar.gz
ports-62c72040c78dfa303a4d0a8ec94eab76397f564c.zip
- Update to version 0.3.6
PR: ports/171967 Submitted by: KATO Tsuguru <tkato432 _at_ yahoo.com> Approved by: beat (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=308039
Diffstat (limited to 'audio/qsynth')
-rw-r--r--audio/qsynth/Makefile31
-rw-r--r--audio/qsynth/distinfo4
-rw-r--r--audio/qsynth/files/patch-src-qsynthOptions.cpp18
-rw-r--r--audio/qsynth/pkg-plist3
4 files changed, 36 insertions, 20 deletions
diff --git a/audio/qsynth/Makefile b/audio/qsynth/Makefile
index fc3ae32b00f5..8f00e864dbe4 100644
--- a/audio/qsynth/Makefile
+++ b/audio/qsynth/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qsynth
-PORTVERSION= 0.3.4
-PORTREVISION= 3
+PORTVERSION= 0.3.6
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28stable%29/${PORTVERSION}
@@ -12,15 +11,31 @@ COMMENT= Qt fluidsynth front-end application
LIB_DEPENDS= fluidsynth:${PORTSDIR}/audio/fluidsynth
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_QT4= gui qmake_build moc_build uic_build rcc_build linguist_build
-CFLAGS+= -I${QT_INCDIR} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}
-LDFLAGS+= -L${QT_LIBDIR}
-CONFIGURE_ARGS+=ac_cv_path_ac_moc=${MOC} ac_cv_path_ac_uic=${UIC} \
+QT_NONSTANDARD= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= ac_cv_path_ac_moc=${MOC} \
+ ac_cv_path_ac_uic=${UIC} \
ac_cv_path_ac_qmake=${QMAKE} \
ac_cv_path_ac_lupdate=${LOCALBASE}/bin/lupdate-qt4 \
ac_cv_path_ac_lrelease=${LOCALBASE}/bin/lrelease-qt4
-MAKE_JOBS_UNSAFE= yes
+INSTALLS_ICONS= yes
+MAKE_JOBS_UNSAFE=yes
+
+CPPFLAGS+= -I${QT_INCDIR} ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${QT_LIBDIR} ${PTHREAD_LIBS}
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|@make |@$$(MAKE) | ; \
+ /man1/s|^|#|' ${WRKSRC}/Makefile.in
+
+post-configure:
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -o qsynth.mak \
+ ${QMAKEFLAGS})
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/qsynth
.include <bsd.port.mk>
diff --git a/audio/qsynth/distinfo b/audio/qsynth/distinfo
index 37f9c64f3987..be839ace096d 100644
--- a/audio/qsynth/distinfo
+++ b/audio/qsynth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qsynth-0.3.4.tar.gz) = 87542acdd2d238d60d1fd26a61157fcdd34c1ce667543f564f31fd027ced8b07
-SIZE (qsynth-0.3.4.tar.gz) = 190655
+SHA256 (qsynth-0.3.6.tar.gz) = b5968da98661bac5c9fcc93d3a15851594dfbf3bb7d01ace15fbe8779d53fb3c
+SIZE (qsynth-0.3.6.tar.gz) = 223774
diff --git a/audio/qsynth/files/patch-src-qsynthOptions.cpp b/audio/qsynth/files/patch-src-qsynthOptions.cpp
index 90e3fac954a8..da0299341304 100644
--- a/audio/qsynth/files/patch-src-qsynthOptions.cpp
+++ b/audio/qsynth/files/patch-src-qsynthOptions.cpp
@@ -1,6 +1,6 @@
---- src/qsynthOptions.cpp.orig 2009-08-27 18:35:48.000000000 +0200
-+++ src/qsynthOptions.cpp 2009-08-27 18:36:39.000000000 +0200
-@@ -155,11 +155,11 @@ void qsynthOptions::print_usage ( const
+--- src/qsynthOptions.cpp.orig 2011-03-30 20:53:04.000000000 +0900
++++ src/qsynthOptions.cpp 2012-09-25 21:29:15.000000000 +0900
+@@ -172,11 +172,11 @@
out << " -n, --no-midi-in" + sEot +
QObject::tr("Don't create a midi driver to read MIDI input events [default = yes]") + sEol;
out << " -m, --midi-driver=[label]" + sEot +
@@ -14,12 +14,12 @@
out << " -j, --connect-jack-outputs" + sEot +
QObject::tr("Attempt to connect the jack outputs to the physical ports") + sEol;
out << " -L, --audio-channels=[num]" + sEot +
-@@ -459,7 +459,7 @@ void qsynthOptions::loadSetup ( qsynthSe
- pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 512).toInt();
- pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 8).toInt();
+@@ -477,7 +477,7 @@
+ pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 512).toInt();
+ pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 8).toInt();
#else
- pSetup->sMidiDriver = m_settings.value("/MidiDriver", "alsa_seq").toString();
+ pSetup->sMidiDriver = m_settings.value("/MidiDriver", "jack").toString();
- pSetup->sAudioDriver = m_settings.value("/AudioDriver", "jack").toString();
- pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 64).toInt();
- pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 2).toInt();
+ pSetup->sAudioDriver = m_settings.value("/AudioDriver", "jack").toString();
+ pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 64).toInt();
+ pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 2).toInt();
diff --git a/audio/qsynth/pkg-plist b/audio/qsynth/pkg-plist
index 0dd5ee6ce06a..4bbc0afcbd84 100644
--- a/audio/qsynth/pkg-plist
+++ b/audio/qsynth/pkg-plist
@@ -1,7 +1,8 @@
bin/qsynth
-share/pixmaps/qsynth.png
share/applications/qsynth.desktop
+share/locale/qsynth_cs.qm
share/locale/qsynth_de.qm
share/locale/qsynth_es.qm
share/locale/qsynth_ru.qm
+share/icons/hicolor/32x32/apps/qsynth.png
@dirrmtry share/applications