aboutsummaryrefslogtreecommitdiff
path: root/audio/raop_play
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-03-23 21:14:39 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-03-23 21:14:39 +0000
commitc6a2501ef2a438d205325e3d382a031aa8486319 (patch)
treee2bedddab94c31b6b603a72007f201b1fd00c442 /audio/raop_play
parentea074376d39570a02a19abe6cb0a09507466fa0a (diff)
downloadports-c6a2501ef2a438d205325e3d382a031aa8486319.tar.gz
ports-c6a2501ef2a438d205325e3d382a031aa8486319.zip
- Chase x11-toolkits/fltk update
Notes
Notes: svn path=/head/; revision=251412
Diffstat (limited to 'audio/raop_play')
-rw-r--r--audio/raop_play/Makefile12
-rw-r--r--audio/raop_play/files/getline.h3
2 files changed, 5 insertions, 10 deletions
diff --git a/audio/raop_play/Makefile b/audio/raop_play/Makefile
index f35e1e575c38..de909fe8edbc 100644
--- a/audio/raop_play/Makefile
+++ b/audio/raop_play/Makefile
@@ -7,7 +7,7 @@
PORTNAME= raop_play
PORTVERSION= 0.5.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= SF/raop-play/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -23,17 +23,11 @@ RUN_DEPENDS= mpg321:${PORTSDIR}/audio/mpg321 \
flac:${PORTSDIR}/audio/flac
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LDFLAGS="`fltk-config --ldflags`"
USE_GMAKE= yes
USE_GNOME= glib20
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800000 && ( ${ARCH} == "amd64" || ${ARCH} == "sparc64" )
-BROKEN= incomplete build
-.endif
-
pre-build:
${CP} ${FILESDIR}/getline.c ${FILESDIR}/getline.h ${WRKSRC}/rendezvous/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/raop_play/files/getline.h b/audio/raop_play/files/getline.h
index 3bbad5698eb3..2816a0641af1 100644
--- a/audio/raop_play/files/getline.h
+++ b/audio/raop_play/files/getline.h
@@ -11,6 +11,7 @@
#define GETLINE_NO_LIMIT -1
+#ifndef _WITH_GETLINE
int
getline __PROTO ((char **_lineptr, size_t *_n, FILE *_stream));
int
@@ -19,5 +20,5 @@ int
int
getstr __PROTO ((char **_lineptr, size_t *_n, FILE *_stream,
int _terminator, int _offset, int limit));
-
+#endif
#endif /* _getline_h_ */