aboutsummaryrefslogtreecommitdiff
path: root/audio/rnnoise
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-07 06:32:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-07 06:32:07 +0000
commitf64fa0b955204bca6d6f683056776320e9af378c (patch)
treec4964cc831139e25ccca7440da784037b73ab0ba /audio/rnnoise
parent39e64e9333bfc4bf1cc83da49aea0a8e6448c0ec (diff)
downloadports-f64fa0b955204bca6d6f683056776320e9af378c.tar.gz
ports-f64fa0b955204bca6d6f683056776320e9af378c.zip
New port: audio/rnnoise: Recurrent neural network for audio noise reduction
Notes
Notes: svn path=/head/; revision=564605
Diffstat (limited to 'audio/rnnoise')
-rw-r--r--audio/rnnoise/Makefile39
-rw-r--r--audio/rnnoise/distinfo3
-rw-r--r--audio/rnnoise/pkg-descr3
3 files changed, 45 insertions, 0 deletions
diff --git a/audio/rnnoise/Makefile b/audio/rnnoise/Makefile
new file mode 100644
index 000000000000..7ff83fc8410c
--- /dev/null
+++ b/audio/rnnoise/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= rnnoise
+DISTVERSION= g20210122
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Recurrent neural network for audio noise reduction
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf gmake libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static --disable-examples
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= xiph
+GH_TAGNAME= 1cbdbcf
+
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_CONFIGURE_ENABLE= doc
+
+PORTDOCS= * # API documentation feature is broken: https://github.com/xiph/rnnoise/issues/44
+
+PLIST_FILES= include/rnnoise.h \
+ lib/librnnoise.so \
+ lib/librnnoise.so.0 \
+ lib/librnnoise.so.0.4.1 \
+ libdata/pkgconfig/rnnoise.pc
+
+post-install-DOCS-on:
+ @${RM} ${STAGEDIR}${DOCSDIR}/COPYING
+
+.include <bsd.port.mk>
diff --git a/audio/rnnoise/distinfo b/audio/rnnoise/distinfo
new file mode 100644
index 000000000000..fe0530752e5f
--- /dev/null
+++ b/audio/rnnoise/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1612679142
+SHA256 (xiph-rnnoise-g20210122-1cbdbcf_GH0.tar.gz) = e2aedecd6ee74c2c04caa90c4f02c4f1ceca6303d4a24bb59f0c00895b4fdcf0
+SIZE (xiph-rnnoise-g20210122-1cbdbcf_GH0.tar.gz) = 173753
diff --git a/audio/rnnoise/pkg-descr b/audio/rnnoise/pkg-descr
new file mode 100644
index 000000000000..1f17a133e7c5
--- /dev/null
+++ b/audio/rnnoise/pkg-descr
@@ -0,0 +1,3 @@
+RNNoise is a noise suppression library based on a recurrent neural network.
+
+WWW: https://github.com/xiph/rnnoise