aboutsummaryrefslogtreecommitdiff
path: root/audio/ruby-xmms2
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-04-01 03:53:48 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-04-01 03:53:48 +0000
commit27430cdee472fe9bbb764432da0ffd56ccb7d7f3 (patch)
tree4f05820d7b8c4c9e8d011f11c764bbcdaca24af2 /audio/ruby-xmms2
parent784eb5c8164b137832c908cb20371065aa58989b (diff)
downloadports-27430cdee472fe9bbb764432da0ffd56ccb7d7f3.tar.gz
ports-27430cdee472fe9bbb764432da0ffd56ccb7d7f3.zip
[NEW PORT] audio/ruby18-xmms2: Rewrite of xmms as a client/server system (developer release)
- ruby binding slave ports for xmms2 - goes along with the DrDolittle update to xmms2 PR: ports/95068 Submitted by: Alexander Botero-Lowry <alex@foxybanana.com>
Notes
Notes: svn path=/head/; revision=158518
Diffstat (limited to 'audio/ruby-xmms2')
-rw-r--r--audio/ruby-xmms2/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/ruby-xmms2/Makefile b/audio/ruby-xmms2/Makefile
new file mode 100644
index 000000000000..8bcc277603f9
--- /dev/null
+++ b/audio/ruby-xmms2/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ruby-xmms2
+# Date created: 18 Mar 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= audio ruby
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= Ruby Bindings for XMMS2
+
+MASTERDIR= ${.CURDIR}/../xmms2
+
+USE_RUBY= yes
+USE_GNOME= glib20
+
+PLIST_FILES= ${RUBY_SITEARCHLIBDIR}/xmmsclient.so \
+ ${RUBY_SITEARCHLIBDIR}/xmmsclient_glib.so
+
+SCONS_TARGET= src/clients/lib/ruby/xmmsclient.so \
+ src/clients/lib/ruby/xmmsclient_glib.so
+XMMS2_SLAVE= ruby
+
+do-install:
+ @cd ${WRKSRC} && ${INSTALL_PROGRAM} src/clients/lib/ruby/xmmsclient.so \
+ ${RUBY_SITEARCHLIBDIR}/xmmsclient.so
+ @cd ${WRKSRC} && ${INSTALL_PROGRAM} \
+ src/clients/lib/ruby/xmmsclient_glib.so \
+ ${RUBY_SITEARCHLIBDIR}/xmmsclient_glib.so
+
+.include "${MASTERDIR}/Makefile"