aboutsummaryrefslogtreecommitdiff
path: root/audio/schism
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-10-04 05:32:07 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-10-04 05:32:07 +0000
commitaa56fe80d317d2c444339fb68580d9d972bc5d06 (patch)
treedb6fc8f8e3abf39586ac1ea7182ad2c1f46d91e5 /audio/schism
parentf4e56360161f07131fd77a21a4f95884a47f2f71 (diff)
downloadports-aa56fe80d317d2c444339fb68580d9d972bc5d06.tar.gz
ports-aa56fe80d317d2c444339fb68580d9d972bc5d06.zip
- Update to 20160521
- 9.x needs a compiler understanding C++11 with a C++11 ready standard library - Relocate to github
Notes
Notes: svn path=/head/; revision=423233
Diffstat (limited to 'audio/schism')
-rw-r--r--audio/schism/Makefile29
-rw-r--r--audio/schism/distinfo5
-rw-r--r--audio/schism/files/patch-modplug_snd__gm.c17
-rw-r--r--audio/schism/files/patch-player_snd__gm.c10
4 files changed, 31 insertions, 30 deletions
diff --git a/audio/schism/Makefile b/audio/schism/Makefile
index e378f4aa840d..58693460939c 100644
--- a/audio/schism/Makefile
+++ b/audio/schism/Makefile
@@ -2,12 +2,8 @@
# $FreeBSD$
PORTNAME= schism
-PORTVERSION= 20100101
-PORTREVISION= 4
+PORTVERSION= 20160521
CATEGORIES= audio
-MASTER_SITES= http://schismtracker.org/dl/ \
- LOCAL/ehaupt
-DISTNAME= schismtracker-${PORTVERSION}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Module tracker editor/player resembling impulse tracker
@@ -16,17 +12,28 @@ LICENSE= GPLv2
ONLY_FOR_ARCHS= i386 amd64
-USES= tar:bzip2
-USE_SDL= yes
+USES= autoreconf python compiler:c++11-lib
+USE_SDL= sdl
USE_XORG= x11 xext xv
GNU_CONFIGURE= yes
-PLIST_FILES= bin/${PORTNAME}
+USE_GITHUB= yes
+GH_ACCOUNT= schismtracker
+GH_PROJECT= schismtracker
-WRKSRC= ${WRKDIR}/${DISTNAME}
+PLIST_FILES= bin/${PORTNAME}
-# releases up to version 20120105 either segfault or don't run
-PORTSCOUT= skipv:20100202,20101127,20101128,20110101,20120105
+# if you touch these make sure configure finds X11/XKBlib.h presence
+LDFLAGS+= `sdl-config --libs`
+LIBS+= -lm -lX11
+CPPFLAGS+= -I${LOCALBASE}/include
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e "s|^\(AC_INIT.*\)\[last_git_commit\]|\1${PORTVERSION}|" \
+ -e '/^m4_define.*last_git_commit.*git/d' \
+ ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -e '/^schismtracker_LDADD/d' ${WRKSRC}/Makefile.am
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/schismtracker ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/audio/schism/distinfo b/audio/schism/distinfo
index 147ccc8c5ebc..f9f260b1175b 100644
--- a/audio/schism/distinfo
+++ b/audio/schism/distinfo
@@ -1,2 +1,3 @@
-SHA256 (schismtracker-20100101.tar.bz2) = bbcd82f0ae9d97361ba21c75296de3481b84cfea2ed9e68a5bafb5364f2a3894
-SIZE (schismtracker-20100101.tar.bz2) = 1047576
+TIMESTAMP = 1475444087
+SHA256 (schismtracker-schismtracker-20160521_GH0.tar.gz) = 9f49028dbf7c90fd0a9f0c664b47e479c81e6d4f746a8624a98de6513911d930
+SIZE (schismtracker-schismtracker-20160521_GH0.tar.gz) = 1026780
diff --git a/audio/schism/files/patch-modplug_snd__gm.c b/audio/schism/files/patch-modplug_snd__gm.c
deleted file mode 100644
index 60641a8da69b..000000000000
--- a/audio/schism/files/patch-modplug_snd__gm.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- modplug/snd_gm.c.orig 2010-01-01 19:22:26 UTC
-+++ modplug/snd_gm.c
-@@ -10,12 +10,14 @@
- #include "mplink.h" // for 'mp', which we shouldn't need
- #include "snd_gm.h"
-
-+/*
- #if !defined(HAVE_LOG2) && !defined(__USE_ISOC99) && !defined(log2)
- static double log2(double d)
- {
- return log(d) / log(2.0);
- }
- #endif
-+*/
-
-
- #define LinearMidivol 1
diff --git a/audio/schism/files/patch-player_snd__gm.c b/audio/schism/files/patch-player_snd__gm.c
new file mode 100644
index 000000000000..645def4b3969
--- /dev/null
+++ b/audio/schism/files/patch-player_snd__gm.c
@@ -0,0 +1,10 @@
+--- player/snd_gm.c.orig 2016-10-03 07:37:10 UTC
++++ player/snd_gm.c
+@@ -33,6 +33,7 @@
+ #include "snd_gm.h"
+
+ #include <math.h> // for log and log2
++#include <tgmath.h>
+ #if !defined(HAVE_LOG2) && !defined(__USE_ISOC99) && !defined(log2)
+ static double log2(double d)
+ {