aboutsummaryrefslogtreecommitdiff
path: root/audio/scrobbler
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-05-10 11:47:46 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-05-10 11:47:46 +0000
commit9f228b923475fc2dc80a2f0149af62725d849541 (patch)
tree56b5f257b4562ecc1bb334697d52261f03ce5076 /audio/scrobbler
parentd5e7720ced5efa938870f50a18c7f57aae39dd15 (diff)
downloadports-9f228b923475fc2dc80a2f0149af62725d849541.tar.gz
ports-9f228b923475fc2dc80a2f0149af62725d849541.zip
Add audio/scrobbler - master port for bmp- and xmms-scrobbler ports.
Notes
Notes: svn path=/head/; revision=134982
Diffstat (limited to 'audio/scrobbler')
-rw-r--r--audio/scrobbler/Makefile56
-rw-r--r--audio/scrobbler/distinfo2
-rw-r--r--audio/scrobbler/pkg-descr5
3 files changed, 63 insertions, 0 deletions
diff --git a/audio/scrobbler/Makefile b/audio/scrobbler/Makefile
new file mode 100644
index 000000000000..cb987742151c
--- /dev/null
+++ b/audio/scrobbler/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: xmms-scrobbler
+# Date created: 2004-12-06
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME?= scrobbler
+PORTVERSION= 0.3.8.1
+CATEGORIES= audio
+MASTER_SITES= http://static.audioscrobbler.com/plugins/ \
+ http://www.pipian.com/stuffforchat/
+DISTNAME= xmms-scrobbler-${PORTVERSION}
+
+MAINTAINER?= novel@FreeBSD.org
+COMMENT?= XMMS/BMP plugin for Audioscrobbler.com
+
+LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
+ curl.3:${PORTSDIR}/ftp/curl
+
+CONFLICTS= bmp-scrobbler-* \
+ xmms-scrobbler-*
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITH_XMMS) && !defined(WITH_BMP)
+WITH_XMMS= yes
+WITH_BMP= yes
+.endif
+
+.if defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+PLIST_FILES+= lib/xmms/General/libxmms_scrobbler.so
+.else
+CONFIGURE_ARGS+= --disable-xmms-plugin
+.endif
+
+.if defined(WITH_BMP)
+LIB_DEPENDS+= beep.2:${PORTSDIR}/multimedia/beep-media-player
+PLIST_FILES+= lib/bmp/General/libbmp_scrobbler.so
+.else
+CONFIGURE_ARGS+= --disable-bmp-plugin
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.if defined(WITH_APE)
+CONFIGURE_ARGS+= --enable-prefer-ape
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/scrobbler/distinfo b/audio/scrobbler/distinfo
new file mode 100644
index 000000000000..98d8f8f791e3
--- /dev/null
+++ b/audio/scrobbler/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmms-scrobbler-0.3.8.1.tar.bz2) = e933c7660fe9103916ca022ec60ad654
+SIZE (xmms-scrobbler-0.3.8.1.tar.bz2) = 257740
diff --git a/audio/scrobbler/pkg-descr b/audio/scrobbler/pkg-descr
new file mode 100644
index 000000000000..6633f904276f
--- /dev/null
+++ b/audio/scrobbler/pkg-descr
@@ -0,0 +1,5 @@
+This is an BMP/XMMS Plugin which sends the Playlist data to
+audioscrobbler.com
+
+WWW: http://www.audioscrobbler.com
+Author: pipian@pipian.com