aboutsummaryrefslogtreecommitdiff
path: root/audio/sdl_sound/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-09-20 11:21:59 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-09-20 11:21:59 +0000
commit0d2725682b8325a08b11592d11062997bb9dc7f2 (patch)
tree46ab0c86563bfc2fbab1ecc5f9dadffb47afe737 /audio/sdl_sound/Makefile
parent750f1f56ed3264341b911b1182fc2f3f4dd609c2 (diff)
downloadports-0d2725682b8325a08b11592d11062997bb9dc7f2.tar.gz
ports-0d2725682b8325a08b11592d11062997bb9dc7f2.zip
- Update devel/sdl12 to version 1.2.11. Now we employ stock SDL directory
structure (i.e. include/SDL for includes and sdl-config for configuration binary) - Update graphics/sdl_ttf to version 2.0.8 - Update graphics/sdl_image to version 1.2.5 - Update audio/sdl_mixer to version 1.2.7 - Update net/sdl_net to version 1.2.6 - Update Mk/bsd.sdl.mk accordingly - Fix dependent ports to fit the new directory structure and avoid several API breakages - Bump up portrevisions for all dependent ports to allow them to be upgraded by portupgrade/portmaster etc tools Approved by: kris (portmgr), sem (mentor)
Notes
Notes: svn path=/head/; revision=173460
Diffstat (limited to 'audio/sdl_sound/Makefile')
-rw-r--r--audio/sdl_sound/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/audio/sdl_sound/Makefile b/audio/sdl_sound/Makefile
index 247fb5e9920b..66c758d935a6 100644
--- a/audio/sdl_sound/Makefile
+++ b/audio/sdl_sound/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sdl_sound
PORTVERSION= 1.0.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= audio
MASTER_SITES= http://www.icculus.org/SDL_sound/downloads/
DISTNAME= SDL_sound-${PORTVERSION}
@@ -20,7 +20,7 @@ USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
@@ -90,8 +90,4 @@ pre-extract:
@${ECHO_MSG} "You can disable support for vorbis by defining WITHOUT_VORBIS."
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|$$(includedir)/SDL|$$(includedir)/SDL11|' \
- ${WRKSRC}/Makefile.in
-
.include <bsd.port.post.mk>