aboutsummaryrefslogtreecommitdiff
path: root/audio/shairport-sync
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-11-20 17:32:49 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-11-20 17:32:49 +0000
commit1b16e9c295ece6a923bb16abb4df68d3bcc2e562 (patch)
tree6b84ea9d52a5d259edc06ef262d06fb3ff98d2f0 /audio/shairport-sync
parente916478cd831e42f7b4cb8eb4369399f6b696abf (diff)
downloadports-1b16e9c295ece6a923bb16abb4df68d3bcc2e562.tar.gz
ports-1b16e9c295ece6a923bb16abb4df68d3bcc2e562.zip
Add shairport-sync 2.8.6, airPlay audio player with multi-room audio
synchronisation capability.
Notes
Notes: svn path=/head/; revision=426607
Diffstat (limited to 'audio/shairport-sync')
-rw-r--r--audio/shairport-sync/Makefile38
-rw-r--r--audio/shairport-sync/distinfo3
-rw-r--r--audio/shairport-sync/files/shairport-sync.in36
-rw-r--r--audio/shairport-sync/pkg-descr7
-rw-r--r--audio/shairport-sync/pkg-plist3
5 files changed, 87 insertions, 0 deletions
diff --git a/audio/shairport-sync/Makefile b/audio/shairport-sync/Makefile
new file mode 100644
index 000000000000..623335125fdd
--- /dev/null
+++ b/audio/shairport-sync/Makefile
@@ -0,0 +1,38 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= shairport-sync
+PORTVERSION= 2.8.6
+CATEGORIES= audio
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= AirPlay audio player with multi-room audio synchronisation capability
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libconfig.so:devel/libconfig \
+ libdaemon.so:devel/libdaemon \
+ libpopt.so:devel/popt \
+ libsoxr.so:audio/libsoxr \
+ libavahi-client.so:net/avahi-app
+
+GNU_CONFIGURE= yes
+USES= autoreconf libtool pkgconfig ssl
+USE_GITHUB= yes
+
+USE_RC_SUBR= ${PORTNAME}
+
+GH_ACCOUNT= mikebrady
+
+CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc \
+ --with-piddir=/var/run/shairport-sync --with-avahi \
+ --with-ssl=openssl --with-metadata --with-soxr --with-alsa \
+ --with-stdout --with-pipe
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -lcrypto
+
+CONFIGURE_ENV+= SSL_CFLAGS=-I${OPENSSLINC} SSL_LIBS=-L${OPENSSLLIB}
+
+.include <bsd.port.mk>
diff --git a/audio/shairport-sync/distinfo b/audio/shairport-sync/distinfo
new file mode 100644
index 000000000000..ca4a751c8d50
--- /dev/null
+++ b/audio/shairport-sync/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1479651183
+SHA256 (mikebrady-shairport-sync-2.8.6_GH0.tar.gz) = 2e73416ac8fdda1657034afaa143f1710852ebed06e0aa43dafc2b7dc5eb653d
+SIZE (mikebrady-shairport-sync-2.8.6_GH0.tar.gz) = 250257
diff --git a/audio/shairport-sync/files/shairport-sync.in b/audio/shairport-sync/files/shairport-sync.in
new file mode 100644
index 000000000000..a3a088ba8141
--- /dev/null
+++ b/audio/shairport-sync/files/shairport-sync.in
@@ -0,0 +1,36 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: shairport_sync
+# REQUIRE: LOGIN avahi_daemon
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf to
+# enable shairport_sync:
+#
+# shairport_sync_enable (bool): Set it to "YES" to enable shaiport.
+# Default is "NO".
+# shairport_sync_flags (flags): Set extra flags here.
+# shairport_sync_flags="-a name" to change Airport name
+# Default is empty "".
+# shairport_sync_user (user): Set user to run shairport_sync.
+# Default is "nobody".
+
+. /etc/rc.subr
+
+name="shairport_sync"
+rcvar=shairport_sync_enable
+
+load_rc_config ${name}
+
+: ${shairport_sync_enable="NO"}
+: ${shairport_sync_user="nobody"}
+
+command="%%PREFIX%%/bin/shairport-sync"
+pidfile="/var/run/shairport-sync/shairport-sync.pid"
+
+command_args="-d -w ${pidfile}"
+start_precmd="install -d -o ${shairport_sync_user} -g wheel -m 755 /var/run/shairport-sync"
+
+run_rc_command "$1"
diff --git a/audio/shairport-sync/pkg-descr b/audio/shairport-sync/pkg-descr
new file mode 100644
index 000000000000..8a42a8e4c4a8
--- /dev/null
+++ b/audio/shairport-sync/pkg-descr
@@ -0,0 +1,7 @@
+Shairport Sync is an AirPlay audio player - it plays audio streamed from iTunes,
+iOS devices and other AirPlay sources such as Quicktime Player and ForkedDaapd,
+among others. Audio played by a Shairport Sync-powered device stays synchronised
+with the source and hence with similar devices playing the same source. In this
+way, synchronised multi-room audio is possible without difficulty.
+
+WWW: https://github.com/mikebrady/shairport-sync
diff --git a/audio/shairport-sync/pkg-plist b/audio/shairport-sync/pkg-plist
new file mode 100644
index 000000000000..cd9e57726405
--- /dev/null
+++ b/audio/shairport-sync/pkg-plist
@@ -0,0 +1,3 @@
+bin/shairport-sync
+man/man7/shairport-sync.7.gz
+@sample etc/shairport-sync.conf.sample