aboutsummaryrefslogtreecommitdiff
path: root/audio/smasher
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-01-25 16:17:52 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-01-25 16:17:52 +0000
commit8d0730214d27d0cd5d6c412894d0a4620511a4c7 (patch)
treebc5176ec64af9f2db1b8b8d8760fee295845ffd7 /audio/smasher
parentf57146fa85eba5afea3ab05f0ef009c039ce661d (diff)
downloadports-8d0730214d27d0cd5d6c412894d0a4620511a4c7.tar.gz
ports-8d0730214d27d0cd5d6c412894d0a4620511a4c7.zip
Trim Makefile header
Set USE_PKGCONFIG Respect PREFIX Reformat description Sort plist
Notes
Notes: svn path=/head/; revision=310982
Diffstat (limited to 'audio/smasher')
-rw-r--r--audio/smasher/Makefile25
-rw-r--r--audio/smasher/pkg-descr8
-rw-r--r--audio/smasher/pkg-plist29
3 files changed, 27 insertions, 35 deletions
diff --git a/audio/smasher/Makefile b/audio/smasher/Makefile
index f07a1c62b1a1..0dad1b3144c5 100644
--- a/audio/smasher/Makefile
+++ b/audio/smasher/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: smasher
-# Date created: 22 June 2009
-# Whom: chris@officialunix.com
-#
+# Created by: chris@officialunix.com
# $FreeBSD$
-#
PORTNAME= smasher
PORTVERSION= 1.1.6
@@ -20,21 +16,18 @@ LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
csound64.5:${PORTSDIR}/audio/csound
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_PKGCONFIG= build
+USE_WX= yes
+WX_CONF_ARGS= absolute
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-CONFIGURE_ARGS= --with-wx-config=${LOCALBASE}/bin/wxgtk2-2.8-config
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_XORG= x11
-USE_LDCONFIG= yes
-USE_GMAKE= yes
-USE_WX= yes
-
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/share/pixmaps|${LOCALBASE}/share/pixmaps|g' \
- ${WRKSRC}/src/Makefile.am ${WRKSRC}/src/Makefile.in
-
- @${REINPLACE_CMD} -e 's|/usr/share/applications|${LOCALBASE}/share/applications|g' \
- ${WRKSRC}/src/Makefile.am ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|/usr/share/pixmaps|${PREFIX}/share/pixmaps|g' \
+ -e 's|/usr/share/applications|${DESKTOPDIR}|g' \
+ ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>
diff --git a/audio/smasher/pkg-descr b/audio/smasher/pkg-descr
index 52e27f793281..397bbbe7a359 100644
--- a/audio/smasher/pkg-descr
+++ b/audio/smasher/pkg-descr
@@ -1,6 +1,6 @@
-Cross-platform audio loop slicer designed to create sliced loops from WAV, MP3,
-FLAC or AIFF files in seconds without a sequencer.
-
-Effects include filter sweeps, phasing, flanging, delay, and distortion.
+Cross-platform audio loop slicer designed to create sliced loops
+from WAV, MP3, FLAC or AIFF files in seconds without a sequencer.
+Effects include filter sweeps, phasing, flanging, delay, and
+distortion.
WWW: http://smasher.sourceforge.net/
diff --git a/audio/smasher/pkg-plist b/audio/smasher/pkg-plist
index fa6db9441dbf..fbf98921f5e4 100644
--- a/audio/smasher/pkg-plist
+++ b/audio/smasher/pkg-plist
@@ -1,21 +1,29 @@
bin/smasher
bin/smashercsound
+share/applications/smasher.desktop
+share/pixmaps/smasher.png
%%DATADIR%%/csd/declick.csd
%%DATADIR%%/csd/enhance.csd
%%DATADIR%%/csd/eq.csd
%%DATADIR%%/csd/freeverb.csd
%%DATADIR%%/csd/pandelay.csd
%%DATADIR%%/csd/smasher_fx_aux.csd
-%%DATADIR%%/png/media-playlist-shuffle-inv.png
-%%DATADIR%%/png/stock_help-agent.png
+%%DATADIR%%/help/ar01s02.html
+%%DATADIR%%/help/ar01s03.html
+%%DATADIR%%/help/ar01s04.html
+%%DATADIR%%/help/ar01s05.html
+%%DATADIR%%/help/elements.html
+%%DATADIR%%/help/index.html
%%DATADIR%%/png/edit-clear-gs.png
%%DATADIR%%/png/edit-redo_gs.png
%%DATADIR%%/png/edit-undo_gs.png
%%DATADIR%%/png/fileopen.png
%%DATADIR%%/png/filesave_gs.png
+%%DATADIR%%/png/gradient-anticlock-spiral_24x24_gauss_gs.png
%%DATADIR%%/png/gtk-media-play-inv.png
%%DATADIR%%/png/logviewer_gs.png
%%DATADIR%%/png/media-playback-pause.png
+%%DATADIR%%/png/media-playlist-shuffle-inv.png
%%DATADIR%%/png/player_play.png
%%DATADIR%%/png/player_play_inv.png
%%DATADIR%%/png/player_stop.png
@@ -26,17 +34,17 @@ bin/smashercsound
%%DATADIR%%/png/stock_data-previous.png
%%DATADIR%%/png/stock_draw-line.png
%%DATADIR%%/png/stock_draw-line_r.png
+%%DATADIR%%/png/stock_help-agent.png
%%DATADIR%%/png/stock_hyperlink.png
%%DATADIR%%/png/stock_id.png
+%%DATADIR%%/png/stock_internet_gs.png
%%DATADIR%%/png/stock_open.png
%%DATADIR%%/png/stock_repeat.png
%%DATADIR%%/png/stock_repeat_inv.png
%%DATADIR%%/png/stock_shuffle.png
-%%DATADIR%%/png/window_nofullscreen_gs.png
-%%DATADIR%%/png/gradient-anticlock-spiral_24x24_gauss_gs.png
%%DATADIR%%/png/warp.png
%%DATADIR%%/png/warp4.png
-%%DATADIR%%/png/stock_internet_gs.png
+%%DATADIR%%/png/window_nofullscreen_gs.png
%%DATADIR%%/presets/amen_break_i.smash
%%DATADIR%%/presets/amen_break_ii.smash
%%DATADIR%%/presets/amen_break_iii.smash
@@ -56,20 +64,11 @@ bin/smashercsound
%%DATADIR%%/samples/John_Williams.wav
%%DATADIR%%/samples/Sine_Wave.wav
%%DATADIR%%/xpm/smashericon.xpm
-%%DATADIR%%/help/ar01s02.html
-%%DATADIR%%/help/ar01s03.html
-%%DATADIR%%/help/ar01s04.html
-%%DATADIR%%/help/ar01s05.html
-%%DATADIR%%/help/elements.html
-%%DATADIR%%/help/index.html
-share/applications/smasher.desktop
-share/pixmaps/smasher.png
@dirrmtry share/applications
-@dirrmtry share/pixmaps
@dirrm %%DATADIR%%/xpm
@dirrm %%DATADIR%%/samples
+@dirrm %%DATADIR%%/presets
@dirrm %%DATADIR%%/png
@dirrm %%DATADIR%%/help
-@dirrm %%DATADIR%%/presets
@dirrm %%DATADIR%%/csd
@dirrm %%DATADIR%%