aboutsummaryrefslogtreecommitdiff
path: root/audio/sonice/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-30 13:49:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-30 13:49:02 +0000
commit1f2ebcefe9372465a7b386a5bf204892c62435dd (patch)
treec3385038b5843ce80f5c0d221d88dc4e1be3601d /audio/sonice/Makefile
parent0aad7231763949504fd0d0079d6cdf165ea37a02 (diff)
downloadports-1f2ebcefe9372465a7b386a5bf204892c62435dd.tar.gz
ports-1f2ebcefe9372465a7b386a5bf204892c62435dd.zip
add sonice 1.2
Sonice eases reencoding of .ogg files
Notes
Notes: svn path=/head/; revision=54026
Diffstat (limited to 'audio/sonice/Makefile')
-rw-r--r--audio/sonice/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/sonice/Makefile b/audio/sonice/Makefile
new file mode 100644
index 000000000000..2b6307ac7abc
--- /dev/null
+++ b/audio/sonice/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: sonice
+# Date created: Jan 30, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sonice
+PORTVERSION= 1.2
+CATEGORIES= audio
+MASTER_SITES= http://www.cyclooctane.com/sonice/release/
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= oggenc:${PORTSDIR}/audio/vorbis-tools \
+ flac:${PORTSDIR}/audio/flac
+
+USE_ZIP= yes
+USE_PYTHON= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sonice.py ${PREFIX}/bin/sonice
+.for file in commatoys ogg
+ ${INSTALL_SCRIPT} ${WRKSRC}/${file}.py ${PYTHON_SITELIBDIR}
+.endfor
+
+.include <bsd.port.mk>