aboutsummaryrefslogtreecommitdiff
path: root/audio/soundtouch
diff options
context:
space:
mode:
authorArmin Pirkovitsch <sperber@FreeBSD.org>2012-11-30 23:51:35 +0000
committerArmin Pirkovitsch <sperber@FreeBSD.org>2012-11-30 23:51:35 +0000
commit91bb36caf5389da894eb10ef223c67d093aa04ab (patch)
treedf0b80b6cf7c3cdf2c28063c8912debe121f639a /audio/soundtouch
parent62c72040c78dfa303a4d0a8ec94eab76397f564c (diff)
downloadports-91bb36caf5389da894eb10ef223c67d093aa04ab.tar.gz
ports-91bb36caf5389da894eb10ef223c67d093aa04ab.zip
- Update to version 1.7.0
- Add MAKE_JOBS_SAFE - Convert to optionsng - Trim Makefile header PR: ports/171968 Submitted by: KATO Tsuguru <tkato432 _at_ yahoo.com> Approved by: beat (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=308040
Diffstat (limited to 'audio/soundtouch')
-rw-r--r--audio/soundtouch/Makefile54
-rw-r--r--audio/soundtouch/distinfo4
-rw-r--r--audio/soundtouch/pkg-plist9
3 files changed, 32 insertions, 35 deletions
diff --git a/audio/soundtouch/Makefile b/audio/soundtouch/Makefile
index a8d73db7272c..fb419bbfc1a9 100644
--- a/audio/soundtouch/Makefile
+++ b/audio/soundtouch/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: SoundTouch
-# Date created: 16 May 2005
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= soundtouch
-DISTVERSION= 1.6.0
+DISTVERSION= 1.7.0
CATEGORIES= audio
MASTER_SITES= http://www.surina.net/soundtouch/
@@ -15,37 +11,37 @@ COMMENT= Open-source audio processing library
LICENSE= LGPL21
-USE_AUTOTOOLS= autoconf automake libtool
-USE_LDCONFIG= yes
-CONFIGURE_ARGS= --enable-shared=yes
-MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
- pkgdoc_DATA="${PORTDOCS}" pkgdocdir="${DOCSDIR}"
-.if !defined(NOPORTDOCS)
-PORTDOCS= README.html
-.endif
+OPTIONS_DEFINE= INTEGER_SAMPLES DOCS
+INTEGER_SAMPLES_DESC= Use integer sample format
+
WRKSRC= ${WRKDIR}/${PORTNAME}
-OPTIONS_DEFINE= INTEGER_SAMPLES
-INTEGER_SAMPLES_DESC= Use integer sample format
+USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
+ACLOCAL_ARGS= -I config/m4
+AUTOMAKE_ARGS= --add-missing --copy --foreign
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MINTEGER_SAMPLES}
CONFIGURE_ARGS+= --enable-integer-samples
.endif
post-patch:
- @${REINPLACE_CMD} -E 's|-O3 ?||' \
- ${WRKSRC}/source/SoundStretch/Makefile.am \
- ${WRKSRC}/source/SoundTouch/Makefile.am
-.if ${ARCH} != "i386" && ${ARCH} != "amd64" && ${ARCH} != "ia64"
- @${REINPLACE_CMD} '/AM_CXXFLAGS=/s|-msse2 ||' \
- ${WRKSRC}/source/SoundTouch/Makefile.am
+ @${REINPLACE_CMD} -e \
+ 's|^pkgdoc_DATA|#pkgdoc_DATA| ; \
+ s|$$(libdir)/pkgconfig|$$(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.am
+ @${FIND} ${WRKSRC}/source -name "Makefile.am" | ${XARGS} \
+ ${REINPLACE_CMD} -e \
+ 's|-O[0-9]|| ; \
+ s|-msse||'
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
.endif
-run-autotools: # see ${WRKSRC}/bootstrap for reference
- @(cd ${CONFIGURE_WRKSRC} && ${SETENV} \
- AUTOMAKE="${AUTOMAKE} --add-missing --foreign --copy" \
- ${AUTORECONF} -fisv)
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/soundtouch/distinfo b/audio/soundtouch/distinfo
index fd00126a215c..dc4745e87e70 100644
--- a/audio/soundtouch/distinfo
+++ b/audio/soundtouch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (soundtouch-1.6.0.tar.gz) = 8776edaf7299ffe1e8c97285f020365a63c0e01aa4f6f7c5fd1d011c0ded278f
-SIZE (soundtouch-1.6.0.tar.gz) = 94852
+SHA256 (soundtouch-1.7.0.tar.gz) = 0c94722ab995489b7816baa553a1cfd433e1005d456382e31defd068b003c848
+SIZE (soundtouch-1.7.0.tar.gz) = 96531
diff --git a/audio/soundtouch/pkg-plist b/audio/soundtouch/pkg-plist
index d2228cef6890..47d82c680e0e 100644
--- a/audio/soundtouch/pkg-plist
+++ b/audio/soundtouch/pkg-plist
@@ -5,10 +5,11 @@ include/soundtouch/FIFOSamplePipe.h
include/soundtouch/STTypes.h
include/soundtouch/SoundTouch.h
include/soundtouch/soundtouch_config.h
-@dirrm include/soundtouch
-lib/libSoundTouch.a
lib/libSoundTouch.la
-lib/libSoundTouch.so.0
lib/libSoundTouch.so
-share/aclocal/soundtouch.m4
+lib/libSoundTouch.so.0
libdata/pkgconfig/soundtouch.pc
+share/aclocal/soundtouch.m4
+%%PORTDOCS%%%%DOCSDIR%%/README.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/soundtouch