aboutsummaryrefslogtreecommitdiff
path: root/audio/spiralsynthmodular
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-05-10 16:35:58 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-05-10 16:35:58 +0000
commit3298519937e291f0df6e7ab783f6895d122e7ea6 (patch)
tree09fe11399c68546ad88fb59cf19ac0e91f0244c2 /audio/spiralsynthmodular
parent26e41fa9ff744700fc899d81b9608048d476ec45 (diff)
downloadports-3298519937e291f0df6e7ab783f6895d122e7ea6.tar.gz
ports-3298519937e291f0df6e7ab783f6895d122e7ea6.zip
- Add staging support
- Use options helpers - Break lines around 80 characters, remove excessive blank ones
Notes
Notes: svn path=/head/; revision=353578
Diffstat (limited to 'audio/spiralsynthmodular')
-rw-r--r--audio/spiralsynthmodular/Makefile51
1 files changed, 15 insertions, 36 deletions
diff --git a/audio/spiralsynthmodular/Makefile b/audio/spiralsynthmodular/Makefile
index 55aee41cc340..27d8616ff278 100644
--- a/audio/spiralsynthmodular/Makefile
+++ b/audio/spiralsynthmodular/Makefile
@@ -16,7 +16,6 @@ BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa \
LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk \
libsndfile.so:${PORTSDIR}/audio/libsndfile
-NO_STAGE= yes
USE_XORG= x11
GNU_CONFIGURE= yes
@@ -26,17 +25,11 @@ CPPFLAGS+= -I${LOCALBASE}/include
WRKSRC= ${WRKDIR}/spiralmodular-0.2.2
-OPTIONS_DEFINE= OPTIMIZED_CFLAGS
-
-.include <bsd.port.pre.mk>
+ia64_BROKEN= Does not compile on ia64
-.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
-CFLAGS+= -O3 -ffast-math
-.endif
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
-.if ${ARCH} == "ia64"
-BROKEN= Does not compile on ia64
-.endif
+OPTIMIZED_CFLAGS_CFLAGS=-O3 -ffast-math
post-patch:
@${REINPLACE_CMD} -E -e 's@(-O3|-ffast-math)@@g; \
@@ -46,40 +39,26 @@ post-patch:
s|^SpiralSound/Plugins/MidiPlugin/Makefile||; \
s|MidiPlugin||' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
@${REINPLACE_CMD} -e 's|-I/usr/X11R6/include|-I${LOCALBASE}/include|' \
${WRKSRC}/SpiralSound/Plugins/LADSPAPlugin/Makefile.in
-
@${REINPLACE_CMD} -e 's|O_SYNC|O_FSYNC|' \
${WRKSRC}/SpiralSound/Midi.C
-
- @${REINPLACE_CMD} -e \
- 's|True|true|; s|False|false|' \
+ @${REINPLACE_CMD} -e 's|True|true|; s|False|false|' \
${WRKSRC}/SpiralSound/Plugins/MatrixPlugin/MatrixPlugin.C
-
- @${REINPLACE_CMD} -e \
- 's|JackPort::||' \
+ @${REINPLACE_CMD} -e 's|JackPort::||' \
${WRKSRC}/SpiralSound/Plugins/JackPlugin/JackPlugin.h
-
- @${REINPLACE_CMD} -e \
- 's|CVGUI::||' \
+ @${REINPLACE_CMD} -e 's|CVGUI::||' \
${WRKSRC}/SpiralSound/Plugins/ControllerPlugin/ControllerPluginGUI.h
-
- @${REINPLACE_CMD} -e \
- 's|Sample::||' \
+ @${REINPLACE_CMD} -e 's|Sample::||' \
${WRKSRC}/SpiralSound/Sample.h
-
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -E -e \
- 's|-ldl||; \
- s|-lrt||; \
- s|g\+\+|$$(CXX)|; \
- /^CC[[:space:]]*=.+$$/d; \
- /^CXX[[:space:]]*=.+$$/d; \
+ 's,-l(dl|rt),,; s|g\+\+|$$(CXX)|; \
+ /^(CC|CXX)[[:space:]]*=.+$$/d; s|-lpthread|${PTHREAD_LIBS}|g; \
s,@FLTK_(C|CXX)FLAGS@,-I${LOCALBASE}/include,; \
- s|-lpthread|${PTHREAD_LIBS}|g'
-
- @${FIND} ${WRKSRC} -type f -name "*.C" -o -name "*.cpp" -o -name "*.h" | ${XARGS} \
- ${REINPLACE_CMD} -e '/^#include <FL/s|.h>$$|.H>|; /^#include "FL/s|.h"$$|.H"|; \
- s|fl_file_chooser.H|Fl_File_Chooser.H|g'
+ s,(bin|lib)dir),DESTDIR)$$(&,'
+ @${FIND} ${WRKSRC} -type f -name "*.C" -o -name "*.cpp" -o -name "*.h" \
+ | ${XARGS} ${REINPLACE_CMD} -e '/^#include <FL/s|.h>$$|.H>|; \
+ /^#include "FL/s|.h"$$|.H"|; \
+ s|fl_file_chooser.H|Fl_File_Chooser.H|g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>