aboutsummaryrefslogtreecommitdiff
path: root/audio/spiralsynthmodular
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-02-26 11:20:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-02-26 11:20:59 +0000
commit53120f2fd01fe27154a5bfe8f8a2f52339f63d15 (patch)
tree12ed72ac7d241274b104350f55fd8a031097596f /audio/spiralsynthmodular
parentb2ea77ac11dd2501ddbb580d6be69cc5e871c781 (diff)
downloadports-53120f2fd01fe27154a5bfe8f8a2f52339f63d15.tar.gz
ports-53120f2fd01fe27154a5bfe8f8a2f52339f63d15.zip
- Trim the Makefile header per new guidelines
- Remove hardcoded shlib ABI versions from LIB_DEPENDS - Drop leading indefinite article and fix a typo in COMMENT - Synchronize port description with COMMENT line - Convert to the new generation OPTIONS framework
Notes
Notes: svn path=/head/; revision=312973
Diffstat (limited to 'audio/spiralsynthmodular')
-rw-r--r--audio/spiralsynthmodular/Makefile28
-rw-r--r--audio/spiralsynthmodular/pkg-descr2
2 files changed, 11 insertions, 19 deletions
diff --git a/audio/spiralsynthmodular/Makefile b/audio/spiralsynthmodular/Makefile
index 09134e4346ff..b4457c95578e 100644
--- a/audio/spiralsynthmodular/Makefile
+++ b/audio/spiralsynthmodular/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: spiralsynthmodular
-# Date created: 2003 Jan 30
-# Whom: David Yeske <dyeske@gmail.com>
-#
+# Created by: David Yeske <dyeske@gmail.com>
# $FreeBSD$
-#
PORTNAME= spiralsynthmodular
PORTVERSION= 0.2.2a
@@ -13,12 +9,12 @@ MASTER_SITES= SF/spiralmodular/spiralmodular/${PORTVERSION}%20%28Latest%20Versio
DISTNAME= spiralmodular-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= An object orientated modular softsynth / sequencer / sampler
+COMMENT= Object-oriented modular softsynth/sequencer/sampler
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa \
jackd:${PORTSDIR}/audio/jack
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- sndfile.1:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk \
+ sndfile:${PORTSDIR}/audio/libsndfile
USE_XORG= x11
GNU_CONFIGURE= yes
@@ -27,22 +23,18 @@ CONFIGURE_ENV= FLTK_CONFIG="${FLTK_CONFIG}" \
LIBS="${LIBS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include
-.if defined(WITH_OPTIMIZED_CFLAGS)
-CFLAGS+= -O3 -ffast-math
-.endif
-
WRKSRC= ${WRKDIR}/spiralmodular-0.2.2
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
+
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64"
-BROKEN= Does not compile on ia64
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
+CFLAGS+= -O3 -ffast-math
.endif
-pre-everything::
-.if !defined(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} "You can enable additional compilation optimizations"
- @${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
+.if ${ARCH} == "ia64"
+BROKEN= Does not compile on ia64
.endif
post-patch:
diff --git a/audio/spiralsynthmodular/pkg-descr b/audio/spiralsynthmodular/pkg-descr
index f82954e78c14..c0f62c862200 100644
--- a/audio/spiralsynthmodular/pkg-descr
+++ b/audio/spiralsynthmodular/pkg-descr
@@ -1,4 +1,4 @@
-SSM is an object orientated modular softsynth / sequencer / sampler.
+SSM is an object-oriented modular softsynth/sequencer/sampler.
You can use it in a fairly straight forward way to make tracks with,
or get very experimental. Audio or control data can be freely passed