aboutsummaryrefslogtreecommitdiff
path: root/audio/spotifyd/Makefile
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2021-10-09 16:31:56 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2021-10-09 16:31:56 +0000
commitac728ac1b426eb023a27779f1f8e388d14dce379 (patch)
treea1c00427d4e549b9a0d15e9f997cf908ac064f00 /audio/spotifyd/Makefile
parent725b7557f3ac61e723ee3ae5acaa0295c783544c (diff)
downloadports-ac728ac1b426eb023a27779f1f8e388d14dce379.tar.gz
ports-ac728ac1b426eb023a27779f1f8e388d14dce379.zip
audio/spotifyd: update to v0.3.2
Major changes: * Updated librespot * Fix build on MacOS M1 (arm) * Improved error messages * Dependency updates
Diffstat (limited to 'audio/spotifyd/Makefile')
-rw-r--r--audio/spotifyd/Makefile92
1 files changed, 63 insertions, 29 deletions
diff --git a/audio/spotifyd/Makefile b/audio/spotifyd/Makefile
index 4016f57c2dfe..1b2eab4dfc37 100644
--- a/audio/spotifyd/Makefile
+++ b/audio/spotifyd/Makefile
@@ -1,7 +1,6 @@
PORTNAME= spotifyd
DISTVERSIONPREFIX= v
-DISTVERSION= 0.3.0
-PORTREVISION= 6
+DISTVERSION= 0.3.2
CATEGORIES= audio
MAINTAINER= rodrigo@FreeBSD.org
@@ -17,10 +16,15 @@ USE_GITHUB= yes
GH_ACCOUNT= Spotifyd
USE_RC_SUBR= spotifyd
-CARGO_CRATES= aes-0.3.2 \
+CARGO_CRATES= addr2line-0.14.1 \
+ adler-0.2.3 \
+ aes-0.3.2 \
+ aes-0.6.0 \
aes-ctr-0.3.0 \
aes-soft-0.3.3 \
+ aes-soft-0.6.4 \
aesni-0.6.0 \
+ aesni-0.10.0 \
aho-corasick-0.7.6 \
alga-0.9.2 \
alsa-0.2.2 \
@@ -33,8 +37,7 @@ CARGO_CRATES= aes-0.3.2 \
atty-0.2.14 \
autocfg-0.1.7 \
autocfg-1.0.0 \
- backtrace-0.3.40 \
- backtrace-sys-0.1.32 \
+ backtrace-0.3.55 \
base64-0.9.3 \
base64-0.10.1 \
base64-0.11.0 \
@@ -47,7 +50,9 @@ CARGO_CRATES= aes-0.3.2 \
block-buffer-0.9.0 \
block-cipher-trait-0.6.2 \
block-modes-0.3.3 \
+ block-modes-0.7.0 \
block-padding-0.1.5 \
+ block-padding-0.2.1 \
boxfnonce-0.1.1 \
bumpalo-3.2.0 \
byte-tools-0.3.1 \
@@ -55,13 +60,18 @@ CARGO_CRATES= aes-0.3.2 \
bytes-0.4.12 \
bytes-0.5.4 \
c2-chacha-0.2.3 \
+ c_linked_list-1.1.1 \
cc-1.0.50 \
cexpr-0.3.6 \
cfg-if-0.1.10 \
+ cfg-if-1.0.0 \
chrono-0.4.11 \
+ cipher-0.2.5 \
clang-sys-0.28.1 \
clap-2.33.0 \
cloudabi-0.0.3 \
+ color-eyre-0.5.10 \
+ color-spantrace-0.1.6 \
core-foundation-0.6.4 \
core-foundation-0.7.0 \
core-foundation-sys-0.5.1 \
@@ -77,6 +87,7 @@ CARGO_CRATES= aes-0.3.2 \
crossbeam-utils-0.6.6 \
crossbeam-utils-0.7.0 \
crypto-mac-0.7.0 \
+ crypto-mac-0.10.0 \
ctr-0.3.2 \
daemonize-0.4.1 \
darling-0.9.0 \
@@ -98,6 +109,7 @@ CARGO_CRATES= aes-0.3.2 \
env_logger-0.7.1 \
error-chain-0.11.0 \
error-chain-0.12.1 \
+ eyre-0.6.5 \
failure-0.1.7 \
failure_derive-0.1.7 \
fake-simd-0.1.2 \
@@ -122,17 +134,22 @@ CARGO_CRATES= aes-0.3.2 \
gcc-0.3.55 \
generic-array-0.12.3 \
generic-array-0.14.4 \
+ get_if_addrs-0.5.3 \
+ get_if_addrs-sys-0.1.1 \
gethostname-0.2.1 \
getopts-0.2.21 \
getrandom-0.1.14 \
+ gimli-0.23.0 \
glob-0.3.0 \
h2-0.2.1 \
heck-0.3.1 \
hermit-abi-0.1.6 \
hex-0.3.2 \
hex-0.4.2 \
- hkdf-0.8.0 \
+ hkdf-0.10.0 \
hmac-0.7.1 \
+ hmac-0.10.1 \
+ hostname-0.3.1 \
http-0.2.0 \
http-body-0.3.1 \
httparse-1.3.4 \
@@ -144,34 +161,36 @@ CARGO_CRATES= aes-0.3.2 \
ident_case-1.0.1 \
idna-0.1.5 \
idna-0.2.0 \
+ indenter-0.3.2 \
indexmap-1.3.0 \
iovec-0.1.4 \
itertools-0.8.2 \
itoa-0.4.4 \
js-sys-0.3.35 \
kernel32-sys-0.2.2 \
- keyring-0.9.0 \
+ keyring-0.10.1 \
language-tags-0.2.2 \
lazy_static-1.4.0 \
lewton-0.9.4 \
- libc-0.2.73 \
+ libc-0.2.82 \
libdbus-sys-0.2.1 \
libloading-0.5.2 \
libm-0.1.4 \
- libmdns-0.2.4 \
+ libmdns-0.2.6 \
libpulse-sys-0.0.0 \
- librespot-0.1.1 \
- librespot-audio-0.1.1 \
- librespot-connect-0.1.1 \
- librespot-core-0.1.1 \
- librespot-metadata-0.1.1 \
- librespot-playback-0.1.1 \
- librespot-protocol-0.1.1 \
- librespot-tremor-0.1.0 \
+ librespot-0.1.5 \
+ librespot-audio-0.1.5 \
+ librespot-connect-0.1.5 \
+ librespot-core-0.1.5 \
+ librespot-metadata-0.1.5 \
+ librespot-playback-0.1.5 \
+ librespot-protocol-0.1.5 \
+ librespot-tremor-0.2.0 \
linear-map-1.2.0 \
lock_api-0.3.3 \
log-0.3.9 \
log-0.4.8 \
+ match_cfg-0.1.0 \
matches-0.1.8 \
matrixmultiply-0.2.3 \
maybe-uninit-2.0.0 \
@@ -179,34 +198,40 @@ CARGO_CRATES= aes-0.3.2 \
memoffset-0.5.3 \
mime-0.3.16 \
mime_guess-2.0.1 \
+ miniz_oxide-0.4.3 \
mio-0.6.21 \
mio-named-pipes-0.1.6 \
mio-uds-0.6.7 \
miow-0.2.1 \
miow-0.3.3 \
- multimap-0.4.0 \
+ multimap-0.8.2 \
nalgebra-0.18.1 \
native-tls-0.2.3 \
net2-0.2.33 \
nix-0.9.0 \
- nix-0.10.0 \
nix-0.14.1 \
nom-4.2.3 \
- num-0.2.1 \
+ num-0.3.1 \
num-bigint-0.2.5 \
+ num-bigint-0.3.1 \
num-complex-0.2.4 \
- num-integer-0.1.42 \
- num-iter-0.1.40 \
+ num-complex-0.3.1 \
+ num-integer-0.1.44 \
+ num-iter-0.1.42 \
num-rational-0.2.3 \
- num-traits-0.2.11 \
+ num-rational-0.3.2 \
+ num-traits-0.2.14 \
num_cpus-1.11.1 \
+ object-0.22.0 \
ogg-0.7.0 \
ogg-sys-0.0.9 \
+ once_cell-1.5.2 \
opaque-debug-0.2.3 \
opaque-debug-0.3.0 \
openssl-0.10.26 \
openssl-probe-0.1.2 \
openssl-sys-0.9.53 \
+ owo-colors-1.2.1 \
parking_lot-0.9.0 \
parking_lot_core-0.6.2 \
pbkdf2-0.3.0 \
@@ -216,6 +241,7 @@ CARGO_CRATES= aes-0.3.2 \
pin-project-0.4.8 \
pin-project-internal-0.4.8 \
pin-project-lite-0.1.4 \
+ pin-project-lite-0.2.4 \
pin-utils-0.1.0-alpha.4 \
pkg-config-0.3.17 \
portaudio-rs-0.3.2 \
@@ -227,9 +253,9 @@ CARGO_CRATES= aes-0.3.2 \
proc-macro-nested-0.1.3 \
proc-macro2-0.4.30 \
proc-macro2-1.0.19 \
- protobuf-2.10.0 \
- protobuf-codegen-2.10.0 \
- protobuf-codegen-pure-2.10.0 \
+ protobuf-2.14.0 \
+ protobuf-codegen-2.14.0 \
+ protobuf-codegen-pure-2.14.0 \
quick-error-1.2.3 \
quote-0.6.13 \
quote-1.0.2 \
@@ -271,7 +297,7 @@ CARGO_CRATES= aes-0.3.2 \
schannel-0.1.16 \
scoped-tls-0.1.2 \
scopeguard-1.0.0 \
- secret-service-1.1.0 \
+ secret-service-1.1.3 \
security-framework-0.3.4 \
security-framework-0.4.4 \
security-framework-sys-0.3.3 \
@@ -285,7 +311,9 @@ CARGO_CRATES= aes-0.3.2 \
sha-1-0.8.2 \
sha-1-0.9.1 \
sha2-0.8.1 \
+ sha2-0.9.2 \
shannon-0.2.0 \
+ sharded-slab-0.1.1 \
shell-words-0.1.0 \
shlex-0.1.1 \
signal-hook-0.1.12 \
@@ -295,7 +323,6 @@ CARGO_CRATES= aes-0.3.2 \
smallvec-0.2.1 \
smallvec-0.6.13 \
smallvec-1.1.0 \
- socket2-0.2.4 \
socket2-0.3.11 \
sourcefile-0.1.4 \
stdweb-0.1.3 \
@@ -305,6 +332,7 @@ CARGO_CRATES= aes-0.3.2 \
structopt-0.3.17 \
structopt-derive-0.4.10 \
subtle-1.0.0 \
+ subtle-2.4.0 \
syn-0.15.44 \
syn-1.0.39 \
syn-mid-0.5.0 \
@@ -339,8 +367,13 @@ CARGO_CRATES= aes-0.3.2 \
tokio-udp-0.1.5 \
tokio-uds-0.2.5 \
tokio-util-0.2.0 \
- toml-0.5.6 \
+ toml-0.5.8 \
tower-service-0.3.0 \
+ tracing-0.1.22 \
+ tracing-attributes-0.1.11 \
+ tracing-core-0.1.17 \
+ tracing-error-0.1.2 \
+ tracing-subscriber-0.2.15 \
try-lock-0.1.0 \
try-lock-0.2.2 \
typenum-1.12.0 \
@@ -384,6 +417,7 @@ CARGO_CRATES= aes-0.3.2 \
winreg-0.6.2 \
ws2_32-sys-0.2.1 \
xdg-2.2.0
+
CARGO_FEATURES= --no-default-features
PLIST_FILES= bin/spotifyd \