aboutsummaryrefslogtreecommitdiff
path: root/audio/squash/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-06-01 13:03:14 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-06-01 13:03:14 +0000
commit886a9071a1cc4b364b0a8ff097f1bd58778aea11 (patch)
treec9d301ed55367daf089b38d9246d62856e45d5db /audio/squash/Makefile
parent0be4595fc26a2cdc85a3d8573c423b1d946cbb77 (diff)
downloadports-886a9071a1cc4b364b0a8ff097f1bd58778aea11.tar.gz
ports-886a9071a1cc4b364b0a8ff097f1bd58778aea11.zip
- USE_(BZIP2|XZ) -> USES= tar:(bzip2|xz)
Notes
Notes: svn path=/head/; revision=356114
Diffstat (limited to 'audio/squash/Makefile')
-rw-r--r--audio/squash/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/audio/squash/Makefile b/audio/squash/Makefile
index 1e90e802b390..f351e2dc41ab 100644
--- a/audio/squash/Makefile
+++ b/audio/squash/Makefile
@@ -19,8 +19,7 @@ LIB_DEPENDS+= libFLAC.so:${PORTSDIR}/audio/flac \
libao.so:${PORTSDIR}/audio/libao
RUN_DEPENDS= id3v2:${PORTSDIR}/audio/id3v2
-USE_BZIP2= yes
-USES= gmake
+USES= tar:bzip2 gmake
USE_RUBY= yes
MAKE_ARGS= CC="${CC}"
@@ -28,9 +27,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
-.endif
post-patch:
@${REINPLACE_CMD} -e "s|--std=gnu99|--std=gnu99 ${CFLAGS} ${PTHREAD_CFLAGS}|; \
@@ -50,11 +47,9 @@ do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/extra/musicdb_lib.rb ${STAGEDIR}${RUBY_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/extra/squash.conf ${STAGEDIR}${PREFIX}/etc/squash.conf.dist
-.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README doc/FEATURES doc/LOCKS doc/INSTALL doc/USERS_GUIDE
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>