aboutsummaryrefslogtreecommitdiff
path: root/audio/squash/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-26 18:51:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-26 18:51:43 +0000
commita6cf5720c796c8010b5b07ed22aa1bc7f367b7bd (patch)
treed533375fb8f6b2766b573f6eeb5dc8f715e68424 /audio/squash/Makefile
parentbf528c4c43ccf36979cdb49b647276819400a9ea (diff)
downloadports-a6cf5720c796c8010b5b07ed22aa1bc7f367b7bd.tar.gz
ports-a6cf5720c796c8010b5b07ed22aa1bc7f367b7bd.zip
- Update to 1.0
PR: ports/63403 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer)
Notes
Notes: svn path=/head/; revision=102226
Diffstat (limited to 'audio/squash/Makefile')
-rw-r--r--audio/squash/Makefile23
1 files changed, 8 insertions, 15 deletions
diff --git a/audio/squash/Makefile b/audio/squash/Makefile
index 446a86c7f2ec..d7dffbf1db7e 100644
--- a/audio/squash/Makefile
+++ b/audio/squash/Makefile
@@ -5,15 +5,10 @@
# $FreeBSD$
PORTNAME= squash
-PORTVERSION= 1.0.p1
-PORTREVISION= 4
+PORTVERSION= 1.0
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
- ${MASTER_SITE_LOCAL:S/$/:local/}
-MASTER_SITE_SUBDIR= ${PORTNAME} \
- pav/:local
-DISTNAME= squash-1.0pre1
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:DEFAULT,local
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= matthias.andree@gmx.de
COMMENT= Learning console-based MP3/OGG player
@@ -26,23 +21,24 @@ LIB_DEPENDS+= FLAC.5:${PORTSDIR}/audio/flac \
ao.3:${PORTSDIR}/audio/libao
RUN_DEPENDS= id3v2:${PORTSDIR}/audio/id3v2
-PKGMESSAGE= ${WRKDIR}/pkg-message
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_RUBY= yes
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e "s|--std=gnu99|${CFLAGS} ${PTHREAD_CFLAGS}|; \
+ @${REINPLACE_CMD} -e "s|--std=gnu99|--std=gnu99 ${CFLAGS} ${PTHREAD_CFLAGS}|; \
s|-Iinclude|-Iinclude -I${LOCALBASE}/include|; \
s|-lpthread|${PTHREAD_LIBS}|; s|-ldl|-L${LOCALBASE}/lib|" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s,/usr/bin/ruby,${RUBY}," \
${WRKSRC}/extra/*.rb
@${REINPLACE_CMD} -e "s,/etc/squash.conf,${PREFIX}/etc/squash.conf," \
${WRKSRC}/src/global.c
- @${SED} "s,%%DD%%,${DOCSDIR}," ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
do-install:
${MKDIR} ${PREFIX}/bin
@@ -51,7 +47,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/extra/${FILE}.rb ${PREFIX}/bin
.endfor
${INSTALL_DATA} ${WRKSRC}/extra/musicdb_lib.rb ${RUBY_SITELIBDIR}
- ${INSTALL_DATA} ${WRKSRC}/extra/squash.conf ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/extra/squash.conf ${PREFIX}/etc/squash.conf.dist
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for i in README doc/FEATURES doc/LOCKS doc/INSTALL doc/USERS_GUIDE
@@ -59,9 +55,6 @@ do-install:
.endfor
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.if ${OSVERSION} < 501100
IGNORE= "ignored: FreeBSD before 5.1 lacks the wordexp interface"