aboutsummaryrefslogtreecommitdiff
path: root/audio/strawberry
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-07-02 21:07:20 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-07-02 21:11:53 +0000
commit2e8b882d18f0661626e28911cee98192ca72a0c7 (patch)
treec978d551cc041a80642f1d26735f87d3d886cfca /audio/strawberry
parent2d3f2d33e22410d46537d51ef1f5426944971fe0 (diff)
downloadports-2e8b882d18f0661626e28911cee98192ca72a0c7.tar.gz
ports-2e8b882d18f0661626e28911cee98192ca72a0c7.zip
audio/strawberry: Fix qt6 flavor crash upon start
The Qt6 SQL drivers were split out of devel/qt6-base in 0f24404c0a02 and put into databases/qt6-base_sqldriver in fe629e0d7c4b, respectively. Strawberry needs the sqlite driver to run or will crash upon startup. For the qt5 flavor, make the sqlite driver a runtime only dependency. It is not needed for the build. MFH: 2023Q3
Diffstat (limited to 'audio/strawberry')
-rw-r--r--audio/strawberry/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/audio/strawberry/Makefile b/audio/strawberry/Makefile
index b3bf30d4e0a8..dd729a0eb35c 100644
--- a/audio/strawberry/Makefile
+++ b/audio/strawberry/Makefile
@@ -1,5 +1,6 @@
PORTNAME= strawberry
DISTVERSION= 1.0.17
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= https://github.com/strawberrymusicplayer/${PORTNAME}/releases/download/${DISTVERSION}/ \
https://files.jkvinge.net/packages/strawberry/
@@ -26,9 +27,9 @@ USES= cmake compiler:c++17-lang desktop-file-utils gettext-runtime \
gnome pkgconfig qt:${FLAVOR:S/qt//} sqlite tar:xz xorg
USE_GNOME= glib20
-_USE_QT5= concurrent core dbus gui network sql sql-sqlite3 widgets \
+_USE_QT5= concurrent core dbus gui network sql sql-sqlite3:run widgets \
x11extras buildtools:build linguisttools:build qmake:build
-_USE_QT6= base tools:build
+_USE_QT6= base sqldriver-sqlite:run tools:build
USE_QT= ${_USE_QT${FLAVOR:S/qt//}}
USE_XORG= ice sm x11 xcb xext