aboutsummaryrefslogtreecommitdiff
path: root/audio/streamripper/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:32:34 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:32:34 +0000
commit17a19dc04e1a016d219d6892da4b45267e069a3d (patch)
treef16cf02a99cfd14adff3dd81db12a4115df6fe18 /audio/streamripper/Makefile
parent13816389f5a9e5555cbbbe66609f5e0ce791a425 (diff)
downloadports-17a19dc04e1a016d219d6892da4b45267e069a3d.tar.gz
ports-17a19dc04e1a016d219d6892da4b45267e069a3d.zip
Convert to new options framework left un converted ports in a* categories
While here trim headers Convert some gnomehack to pathfix Convert some pkgconfig to USE_PKGCONFIG=build
Notes
Notes: svn path=/head/; revision=314853
Diffstat (limited to 'audio/streamripper/Makefile')
-rw-r--r--audio/streamripper/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/audio/streamripper/Makefile b/audio/streamripper/Makefile
index 80ccc00d3240..91d4f11e002c 100644
--- a/audio/streamripper/Makefile
+++ b/audio/streamripper/Makefile
@@ -17,8 +17,8 @@ COMMENT= Splits SHOUTcast stream into tracks
LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
tre.5:${PORTSDIR}/textproc/libtre
-OPTIONS= FAAD "Include FAAD mpeg4 codec support" on \
- VORBIS "Include Ogg Vorbis codec support" on
+OPTIONS_DEFINE= FAAD VORBIS
+OPTIONS_DEFAULT= FAAD VORBIS
LICENSE= GPLv2
@@ -39,15 +39,15 @@ LDFLAGS+= -Lcdk-${CDK_VERSION} -L${LOCALBASE}/lib
CDK_VERSION= 5.0-20060507
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_FAAD)
+.if ! ${PORT_OPTIONS:MFAAD}
CONFIGURE_ARGS+= ac_cv_lib_faad_NeAACDecDecode2=no
.else
LIB_DEPENDS+= faad.2:${PORTSDIR}/audio/faad
.endif
-.if defined(WITHOUT_VORBIS)
+.if ! ${PORT_OPTIONS:MVORBIS}
CONFIGURE_ARGS+= --without-ogg
.else
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
@@ -73,4 +73,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/streamripper ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/streamripper.1 ${MANPREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>