aboutsummaryrefslogtreecommitdiff
path: root/audio/streamripper
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-02-07 13:16:27 +0000
committerJohn Marino <marino@FreeBSD.org>2016-02-07 13:16:27 +0000
commit88a5931a2a4059947f7d811d9a7d5cf1984ff2aa (patch)
treec1badfeac6abefdf4feb41a9e98e2f1f144721ad /audio/streamripper
parent53228a5bb104db144e5489946ed17fd285a17cbe (diff)
downloadports-88a5931a2a4059947f7d811d9a7d5cf1984ff2aa.tar.gz
ports-88a5931a2a4059947f7d811d9a7d5cf1984ff2aa.zip
audio/streamripper: USES+= ncurses, respect LDFLAGS
Also: * bring in dports patch to support DF * Modify build to avoid potential name clash with menu.h (the same file name exists on ncurses, common issue)
Notes
Notes: svn path=/head/; revision=408404
Diffstat (limited to 'audio/streamripper')
-rw-r--r--audio/streamripper/Makefile11
-rw-r--r--audio/streamripper/files/patch-cdk-5.0-20060507_configure11
2 files changed, 19 insertions, 3 deletions
diff --git a/audio/streamripper/Makefile b/audio/streamripper/Makefile
index 1e1c847e6627..1471a7b02e40 100644
--- a/audio/streamripper/Makefile
+++ b/audio/streamripper/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libmad.so:${PORTSDIR}/audio/libmad \
OPTIONS_DEFINE= FAAD VORBIS
OPTIONS_DEFAULT=FAAD VORBIS
-USES= iconv pkgconfig
+USES= iconv ncurses pkgconfig
USE_GNOME= glib20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-libmad \
@@ -47,12 +47,17 @@ VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
post-extract:
${MV} ${WRKDIR}/cdk-${CDK_VERSION} ${WRKSRC}
-post-patch:
+xpost-patch:
@${REINPLACE_CMD} -e '/if test/s|==|=|g' ${WRKSRC}/configure
+# avoid potential name conflict with ncurses
+ @${LN} -sv ${WRKSRC}/cdk-5.0-20060507/include/menu.h \
+ ${WRKSRC}/cdk-5.0-20060507/include/cdkmenu.h
+ @${REINPLACE_CMD} -e "s|<menu.h>|<cdkmenu.h>|g" \
+ ${WRKSRC}/cdk-5.0-20060507/include/cdk.h
pre-configure:
(cd ${WRKSRC}/cdk-${CDK_VERSION} && ${SETENV} CC="${CC}" \
- CFLAGS="${CFLAGS}" ${SH} ./configure)
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${SH} ./configure)
pre-build:
(cd ${WRKSRC}/cdk-${CDK_VERSION} && ${SETENV} ${MAKE_ENV} \
diff --git a/audio/streamripper/files/patch-cdk-5.0-20060507_configure b/audio/streamripper/files/patch-cdk-5.0-20060507_configure
new file mode 100644
index 000000000000..8b671d1b712b
--- /dev/null
+++ b/audio/streamripper/files/patch-cdk-5.0-20060507_configure
@@ -0,0 +1,11 @@
+--- cdk-5.0-20060507/configure.orig 2005-12-28 22:41:24 UTC
++++ cdk-5.0-20060507/configure
+@@ -1993,7 +1993,7 @@ case $host_os in #(vi
+ aix[45]*) #(vi
+ CPPFLAGS="$CPPFLAGS -D_ALL_SOURCE"
+ ;;
+-freebsd*) #(vi
++freebsd*|dragonfly*) #(vi
+ # 5.x headers associate
+ # _XOPEN_SOURCE=600 with _POSIX_C_SOURCE=200112L
+ # _XOPEN_SOURCE=500 with _POSIX_C_SOURCE=199506L