aboutsummaryrefslogtreecommitdiff
path: root/audio/stymulator
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-02-07 13:18:31 +0000
committerJohn Marino <marino@FreeBSD.org>2016-02-07 13:18:31 +0000
commit0855b9006de3160d1497015951560261d1bfe833 (patch)
tree07d5cc7c60b5929f56c0fd8f0e8981dbf6487e83 /audio/stymulator
parent88a5931a2a4059947f7d811d9a7d5cf1984ff2aa (diff)
downloadports-0855b9006de3160d1497015951560261d1bfe833.tar.gz
ports-0855b9006de3160d1497015951560261d1bfe833.zip
audio/stymulator: document ncurses rqmt (USES+=ncurses), respect LDFLAGS
approved by: infrastructure blanket
Notes
Notes: svn path=/head/; revision=408405
Diffstat (limited to 'audio/stymulator')
-rw-r--r--audio/stymulator/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/audio/stymulator/Makefile b/audio/stymulator/Makefile
index 1e6533532405..f0b342dbdfb2 100644
--- a/audio/stymulator/Makefile
+++ b/audio/stymulator/Makefile
@@ -14,7 +14,7 @@ COMMENT= Command-line Yamaha YM2149 (.ym) chiptune player
LICENSE= GPLv2
-USES= dos2unix
+USES= dos2unix ncurses
MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src
@@ -23,6 +23,10 @@ MANPAGE1= ymplayer.1 ym2wav.1
PLIST_FILES= bin/ym2wav bin/ymplayer bin/stymulator man/man1/ymplayer.1.gz \
man/man1/ym2wav.1.gz
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lncurses|$$(LDFLAGS) -lncurses|' \
+ ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ym2wav ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/ymplayer ${STAGEDIR}${PREFIX}/bin