aboutsummaryrefslogtreecommitdiff
path: root/audio/stymulator
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-09-24 13:04:52 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-09-24 13:11:53 +0000
commitd51bc0de306aafb68e7af0a6d16b261dcbd83f95 (patch)
tree8ae4e470daacfb6892ee7bf60d24f3b01911345b /audio/stymulator
parent7bcdcaa5437f420895609d977bdea0f6e8589e9d (diff)
downloadports-d51bc0de306aafb68e7af0a6d16b261dcbd83f95.tar.gz
ports-d51bc0de306aafb68e7af0a6d16b261dcbd83f95.zip
ncurses: partial revert 266130ce71ef2f1cd944a70789bf003da3254c29
In many places I overlooked at the problem we were trying to solve when libncurses is split.
Diffstat (limited to 'audio/stymulator')
-rw-r--r--audio/stymulator/Makefile1
-rw-r--r--audio/stymulator/files/patch-Makefile2
2 files changed, 1 insertions, 2 deletions
diff --git a/audio/stymulator/Makefile b/audio/stymulator/Makefile
index 81167ba9fcf2..7442b99cd4f9 100644
--- a/audio/stymulator/Makefile
+++ b/audio/stymulator/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
MANPAGE1= ymplayer.1 ym2wav.1
PLIST_FILES= bin/ym2wav bin/ymplayer bin/stymulator man/man1/ymplayer.1.gz \
man/man1/ym2wav.1.gz
-LDFLAGS+= ${NCURSESLIBS}
post-patch:
@${REINPLACE_CMD} -e 's|-lncurses|$$(LDFLAGS) -lncurses|' \
diff --git a/audio/stymulator/files/patch-Makefile b/audio/stymulator/files/patch-Makefile
index e0fbec9f6f55..698c78ea0bba 100644
--- a/audio/stymulator/files/patch-Makefile
+++ b/audio/stymulator/files/patch-Makefile
@@ -13,7 +13,7 @@
ymplayer: ymplayer.o sound.o ui.o
- $(CC) -o ymplayer $(INCLUDE) ymplayer.o sound.o ui.o -lasound -lym -llzh -lncurses
-+ $(CXX) $(CXXFLAGS) -o ymplayer $(INCLUDE) ymplayer.o sound.o ui.o -lym -llzh ${LFFLAGS} -lncurses
++ $(CXX) $(CXXFLAGS) -o ymplayer $(INCLUDE) ymplayer.o sound.o ui.o -lym -llzh -lncurses
ym2wav: ym2wav.o
- $(CC) -o ym2wav $(INCLUDE) ym2wav.o -lym -llzh