aboutsummaryrefslogtreecommitdiff
path: root/audio/taglib-sharp
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2008-08-27 16:37:59 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2008-08-27 16:37:59 +0000
commit566395bcbb0f02eee6cf846f38e45796a95bd490 (patch)
treeb3fc4e77f01f6f360428bfd2b0ab40e9ebc8559c /audio/taglib-sharp
parentc60789890c95e7c72f61f5bc16bd49c43dac0030 (diff)
downloadports-566395bcbb0f02eee6cf846f38e45796a95bd490.tar.gz
ports-566395bcbb0f02eee6cf846f38e45796a95bd490.zip
Add audio/taglib-sharp, a tagging library for the mono framework.
Notes
Notes: svn path=/head/; revision=219327
Diffstat (limited to 'audio/taglib-sharp')
-rw-r--r--audio/taglib-sharp/Makefile36
-rw-r--r--audio/taglib-sharp/distinfo3
-rw-r--r--audio/taglib-sharp/pkg-descr13
-rw-r--r--audio/taglib-sharp/pkg-plist14
4 files changed, 66 insertions, 0 deletions
diff --git a/audio/taglib-sharp/Makefile b/audio/taglib-sharp/Makefile
new file mode 100644
index 000000000000..adc31c2ff1ec
--- /dev/null
+++ b/audio/taglib-sharp/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: taglib-sharp
+# Date Created: Aug 25 2008
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= taglib-sharp
+PORTVERSION= 2.0.3.0
+CATEGORIES= audio
+MASTER_SITES= http://www.taglib-sharp.com/Download/
+
+MAINTAINER= flz@FreeBSD.org
+COMMENT= Tagging library for the Mono framework
+
+LIB_PC_DEPENDS= mono.pc:${PORTSDIR}/lang/mono
+
+BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|}
+RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|}
+
+OPTIONS= DOCS "Install documentation" on
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+
+.if !defined(WITHOUT_DOCS) && !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/monodocer:${PORTSDIR}/devel/monodoc
+.else
+CONFIGURE_ARGS+= --disable-docs
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/taglib-sharp/distinfo b/audio/taglib-sharp/distinfo
new file mode 100644
index 000000000000..519453792f30
--- /dev/null
+++ b/audio/taglib-sharp/distinfo
@@ -0,0 +1,3 @@
+MD5 (taglib-sharp-2.0.3.0.tar.gz) = aa2c344760c8f4d878957fd4600155a5
+SHA256 (taglib-sharp-2.0.3.0.tar.gz) = b931e5c22fca58adf0ae2f74b8a49c855c4d1dfcf6c2bb725bb4687d1b5e00bd
+SIZE (taglib-sharp-2.0.3.0.tar.gz) = 352463
diff --git a/audio/taglib-sharp/pkg-descr b/audio/taglib-sharp/pkg-descr
new file mode 100644
index 000000000000..c8d7705e9983
--- /dev/null
+++ b/audio/taglib-sharp/pkg-descr
@@ -0,0 +1,13 @@
+TagLib# is a FREE and Open Source library for the .NET 2.0 and Mono
+frameworks which will let you tag your software with as much or as
+little detail as you like without slowing you down. It supports a large
+variety of movie and music formats which abstract away the work,
+handling all the different cases, so all you have to do is access
+file.Tag.Title, file.Tag.Lyrics, or my personal favorite
+file.Tag.Pictures.
+
+But don't think all this abstraction is gonna keep you from tagging's
+greatest gems. You can still get to a specific tag type's features with
+just a few lines of code.
+
+WWW: http://www.taglib-sharp.com/Main_Page
diff --git a/audio/taglib-sharp/pkg-plist b/audio/taglib-sharp/pkg-plist
new file mode 100644
index 000000000000..cf239d6369c5
--- /dev/null
+++ b/audio/taglib-sharp/pkg-plist
@@ -0,0 +1,14 @@
+lib/mono/gac/policy.2.0.taglib-sharp/0.0.0.0__db62eba44689b5b0/policy.2.0.taglib-sharp.config
+lib/mono/gac/policy.2.0.taglib-sharp/0.0.0.0__db62eba44689b5b0/policy.2.0.taglib-sharp.dll
+lib/mono/gac/taglib-sharp/2.0.3.0__db62eba44689b5b0/taglib-sharp.dll
+lib/mono/gac/taglib-sharp/2.0.3.0__db62eba44689b5b0/taglib-sharp.dll.mdb
+lib/mono/taglib-sharp/taglib-sharp.dll
+%%PORTDOCS%%lib/monodoc/sources/taglib-sharp-docs.source
+%%PORTDOCS%%lib/monodoc/sources/taglib-sharp-docs.tree
+%%PORTDOCS%%lib/monodoc/sources/taglib-sharp-docs.zip
+libdata/pkgconfig/taglib-sharp.pc
+@dirrm lib/mono/taglib-sharp
+@dirrm lib/mono/gac/taglib-sharp/2.0.3.0__db62eba44689b5b0
+@dirrm lib/mono/gac/taglib-sharp
+@dirrm lib/mono/gac/policy.2.0.taglib-sharp/0.0.0.0__db62eba44689b5b0
+@dirrm lib/mono/gac/policy.2.0.taglib-sharp