aboutsummaryrefslogtreecommitdiff
path: root/audio/uade
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2010-03-20 21:34:51 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2010-03-20 21:34:51 +0000
commit4fdaed942d7ff27d0b5b2f69bb2d83a5b948bdee (patch)
treee19cb863e5a43508adb4eaa72df86c674175f120 /audio/uade
parent7a149bee8a6119365b99de1c787bf4b90ff4a149 (diff)
downloadports-4fdaed942d7ff27d0b5b2f69bb2d83a5b948bdee.tar.gz
ports-4fdaed942d7ff27d0b5b2f69bb2d83a5b948bdee.zip
Discontinue audacious plugin support. The plugin won't build after audacious
has changed the API [1]. The option will be added again if the plugin gets fixed by the upstream project. [1] http://board.kohina.net/viewtopic.php?t=1212&sid=b6dea715bf62b1d9607435a16dfdd8d5 PR: 144903 (based on) Submitted by: CeDeROM <tomek.cedro@gmail.com>
Notes
Notes: svn path=/head/; revision=251316
Diffstat (limited to 'audio/uade')
-rw-r--r--audio/uade/Makefile13
-rw-r--r--audio/uade/files/patch-src-frontends-audacious-plugin.c23
-rw-r--r--audio/uade/pkg-plist1
3 files changed, 2 insertions, 35 deletions
diff --git a/audio/uade/Makefile b/audio/uade/Makefile
index c99806cc816e..5d4062431784 100644
--- a/audio/uade/Makefile
+++ b/audio/uade/Makefile
@@ -24,7 +24,7 @@ DOCSDIR= ${PREFIX}/share/doc/uade2
DATADIR= ${PREFIX}/share/uade2
CONFIGURE_ARGS= --prefix=${PREFIX} \
--mandir=${MANPREFIX}/man/man1 \
- --no-debug
+ --no-debug --without-audacious
CONFIGURE_ENV= SYSCFLAGS='${CFLAGS}'
@@ -35,21 +35,12 @@ PORTDOCS= BUGS PLANS REDUNDANT_REPLAYERS UAE-CREDITS UAE-README \
play_loop_state_diagram.dia play_loop_state_diagram.eps \
play_loop_state_diagram.txt uade.html
-OPTIONS= AUDACIOUS "Audacious plugin" off \
- TEXT_SCOPE "Audio register debug mode" off \
+OPTIONS= TEXT_SCOPE "Audio register debug mode" off \
UADEFS "FUSE filesystem" off \
XMMS "XMMS plugin" off
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_AUDACIOUS)
-LIB_DEPENDS+= audclient.2:${PORTSDIR}/multimedia/audacious
-PLIST_SUB+= AUDACIOUS=""
-.else
-CONFIGURE_ARGS+=--without-audacious
-PLIST_SUB+= AUDACIOUS="@comment "
-.endif
-
.if !defined(WITHOUT_TEXT_SCOPE)
CONFIGURE_ARGS+=--with-text-scope
.endif
diff --git a/audio/uade/files/patch-src-frontends-audacious-plugin.c b/audio/uade/files/patch-src-frontends-audacious-plugin.c
deleted file mode 100644
index 209dcdde4395..000000000000
--- a/audio/uade/files/patch-src-frontends-audacious-plugin.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/frontends/audacious/plugin.c~
-+++ src/frontends/audacious/plugin.c
-@@ -75,6 +75,10 @@ static void uade_seek(int time);
-
- /* GLOBAL VARIABLE DECLARATIONS */
-
-+static gchar *fmts[] = {
-+ "ahx", NULL
-+};
-+
- static InputPlugin uade_ip = {
- .description = "UADE " UADE_VERSION,
- .init = uade_init,
-@@ -87,6 +90,9 @@ static InputPlugin uade_ip = {
- .cleanup = uade_cleanup,
- .get_song_info = uade_get_song_info,
- .file_info_box = uade_file_info,
-+#ifdef __AUDACIOUS_INPUT_PLUGIN_API__
-+ .vfs_extensions = fmts,
-+#endif
- };
-
- #ifndef __AUDACIOUS_INPUT_PLUGIN_API__
diff --git a/audio/uade/pkg-plist b/audio/uade/pkg-plist
index fd3366e15b99..ba7d184f3ccb 100644
--- a/audio/uade/pkg-plist
+++ b/audio/uade/pkg-plist
@@ -2,7 +2,6 @@ bin/mod2ogg2.sh
bin/uade123
%%UADEFS%%bin/uadefs
%%XMMS%%bin/uadexmmsadd
-%%AUDACIOUS%%lib/audacious/Input/libuade2.so
lib/uade2/uadecore
%%XMMS%%lib/xmms/Input/libuade2.so
libdata/pkgconfig/uade.pc