aboutsummaryrefslogtreecommitdiff
path: root/audio/vgmplay/Makefile
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2021-01-07 21:51:08 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2021-01-07 21:51:08 +0000
commit09772afb04a474c193069b323ae28fe5077e15b0 (patch)
tree908343ae19de486d8f137c0aa701fce6621bc2e0 /audio/vgmplay/Makefile
parent3ad5db75cfd3b0c575c8c2209ef8f5a3826a10a7 (diff)
downloadports-09772afb04a474c193069b323ae28fe5077e15b0.tar.gz
ports-09772afb04a474c193069b323ae28fe5077e15b0.zip
- Fix build with -fno-common (clang 11 and gcc 10)
- Use MANPREFIX/share/man for manpage path - Remove over-optimization - Bump port revision for package change Reviewed by: ehaupt MFH: 2021Q1
Notes
Notes: svn path=/head/; revision=560739
Diffstat (limited to 'audio/vgmplay/Makefile')
-rw-r--r--audio/vgmplay/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/audio/vgmplay/Makefile b/audio/vgmplay/Makefile
index b4c015c14e95..b434f0b31a3e 100644
--- a/audio/vgmplay/Makefile
+++ b/audio/vgmplay/Makefile
@@ -2,7 +2,7 @@
PORTNAME= vgmplay
PORTVERSION= 0.40.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= https://github.com/vgmrips/${PORTNAME}/releases/download/${PORTVERSION}/
DISTNAME= ${PORTNAME:S/vgmp/VGMP/}_${PORTVERSION:S/.//:S/./-/}_src
@@ -35,7 +35,7 @@ MAKE_ENV_powerpc64= BYTE_ORDER=2
MAKE_ENV_powerpc64le= BYTE_ORDER=1
MAKE_ENV_powerpcspe= BYTE_ORDER=2
-PLIST_FILES= bin/vgmplay bin/vgm2pcm bin/vgm2wav man/man1/vgmplay.1.gz ${EXAMPLESDIR}/vgmplay.ini
+PLIST_FILES= bin/vgmplay bin/vgm2pcm bin/vgm2wav share/man/man1/vgmplay.1.gz ${EXAMPLESDIR}/vgmplay.ini
.include <bsd.port.pre.mk>
@@ -50,7 +50,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vgmplay ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/vgm2pcm ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/vgm2wav ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/vgmplay.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/vgmplay.1 ${STAGEDIR}${MANPREFIX}/share/man/man1
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/VGMPlay.ini ${STAGEDIR}${EXAMPLESDIR}/vgmplay.ini