aboutsummaryrefslogtreecommitdiff
path: root/audio/wavbreaker
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-04-08 01:55:38 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-04-08 01:55:38 +0000
commitb898147203abdcd0d5664d84becad038947e84b0 (patch)
treeb04798668cb21cc4006e4f230ff1683a0a01aa57 /audio/wavbreaker
parentad9c9f31502ad2c8712ad929d8191172ac6445c6 (diff)
downloadports-b898147203abdcd0d5664d84becad038947e84b0.tar.gz
ports-b898147203abdcd0d5664d84becad038947e84b0.zip
- Convert to option helpers
- Don't alter default exported PKG_CONFIG - Clarify LICENSE allows future GPL versions - Take maintainership
Notes
Notes: svn path=/head/; revision=383553
Diffstat (limited to 'audio/wavbreaker')
-rw-r--r--audio/wavbreaker/Makefile27
1 files changed, 8 insertions, 19 deletions
diff --git a/audio/wavbreaker/Makefile b/audio/wavbreaker/Makefile
index 2976dae6dccc..0443ec978599 100644
--- a/audio/wavbreaker/Makefile
+++ b/audio/wavbreaker/Makefile
@@ -7,36 +7,25 @@ PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jbeich@FreeBSD.org
COMMENT= Tool to split and merge wav files
-LICENSE= GPLv2
+LICENSE= GPLv2 # or any later version
OPTIONS_DEFINE= PULSEAUDIO NLS
+OPTIONS_SUB= yes
+
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+PULSEAUDIO_CONFIGURE_ENABLE=pulse
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
USE_GNOME= gtk20 libxml2
USES= gmake pathfix pkgconfig desktop-file-utils
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PKG_CONFIG="${LOCALBASE}/bin/pkg-config"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-alsa
INSTALLS_ICONS= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPULSEAUDIO}
-LIB_DEPENDS+= libpulse.so:${PORTSDIR}/audio/pulseaudio
-.else
-CONFIGURE_ARGS+=--disable-pulse
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB= NLS="@comment "
-.endif
-
.include <bsd.port.mk>