aboutsummaryrefslogtreecommitdiff
path: root/audio/wmix/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-15 11:45:37 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-15 11:45:37 +0000
commit079a18698cc5899903d077689afd8e908c18422a (patch)
treef119315cd9d0e299c299392eb895137717bee659 /audio/wmix/Makefile
parent2edb464958870db81176ff33d87a303089f7854c (diff)
downloadports-079a18698cc5899903d077689afd8e908c18422a.tar.gz
ports-079a18698cc5899903d077689afd8e908c18422a.zip
- Update to 3.1
- Install documentation - Assign maintership to submitter PR: ports/69056 Submitted by: Roman Bogorodskiy
Notes
Notes: svn path=/head/; revision=113708
Diffstat (limited to 'audio/wmix/Makefile')
-rw-r--r--audio/wmix/Makefile24
1 files changed, 19 insertions, 5 deletions
diff --git a/audio/wmix/Makefile b/audio/wmix/Makefile
index f278ba7a38be..5dc850e25aa0 100644
--- a/audio/wmix/Makefile
+++ b/audio/wmix/Makefile
@@ -6,18 +6,32 @@
#
PORTNAME= wmix
-PORTVERSION= 2.20
+PORTVERSION= 3.1
CATEGORIES= audio windowmaker
MASTER_SITES= http://www.ne.jp/asahi/linux/timecop/software/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bogorodskiy@inbox.ru
COMMENT= An audio mixer for the WindowMaker dock with TV-like OSD
+USE_REINPLACE= yes
PLIST_FILES= bin/wmix
-USE_XPM= YES
-USE_X_PREFIX= YES
+ALL_TARGET= ${PORTNAME}
+USE_XPM= yes
+USE_X_PREFIX= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I${X11BASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${X11BASE}/lib"
+
+PORTDOCS= AUTHORS BUGS INSTALL NEWS README
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/wmix ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/wmix ${PREFIX}/bin
+
+post-install:
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>