aboutsummaryrefslogtreecommitdiff
path: root/audio/wmsmixer
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2002-11-18 03:00:41 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2002-11-18 03:00:41 +0000
commit91d717cd152231088ac89273ce15b6d34c01fc8b (patch)
tree801e4b912a6a24444c660405d1e35ee5b5a37fa0 /audio/wmsmixer
parentd24d9d7c7bc44d969c9be15840dd6db0e8995e2d (diff)
downloadports-91d717cd152231088ac89273ce15b6d34c01fc8b.tar.gz
ports-91d717cd152231088ac89273ce15b6d34c01fc8b.zip
Unbreak on -current.
Notes
Notes: svn path=/head/; revision=70357
Diffstat (limited to 'audio/wmsmixer')
-rw-r--r--audio/wmsmixer/Makefile1
-rw-r--r--audio/wmsmixer/files/patch-wmsmixer.cc11
2 files changed, 12 insertions, 0 deletions
diff --git a/audio/wmsmixer/Makefile b/audio/wmsmixer/Makefile
index 95bc8dc04bf1..f465d70a1572 100644
--- a/audio/wmsmixer/Makefile
+++ b/audio/wmsmixer/Makefile
@@ -14,5 +14,6 @@ MAINTAINER= kkonstan@daemon.gr
USE_XPM= YES
USE_IMAKE= YES
+MAKE_ARGS= CC=g++
.include <bsd.port.mk>
diff --git a/audio/wmsmixer/files/patch-wmsmixer.cc b/audio/wmsmixer/files/patch-wmsmixer.cc
new file mode 100644
index 000000000000..56125c68a1a6
--- /dev/null
+++ b/audio/wmsmixer/files/patch-wmsmixer.cc
@@ -0,0 +1,11 @@
+--- wmsmixer.cc.orig Tue Mar 6 07:39:43 2001
++++ wmsmixer.cc Sat Nov 16 14:22:26 2002
+@@ -547,7 +547,7 @@
+ }
+ }
+
+-void checkVol(bool forced=true)
++void checkVol(bool forced)
+ {
+ mixctl->readVol(channel[curchannel], true);
+ int nl=mixctl->readLeft(channel[curchannel]);