aboutsummaryrefslogtreecommitdiff
path: root/audio/wmsmixer
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
commit932db7c46c9a269808dfa67ea02746b350c194d8 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /audio/wmsmixer
parentb9b5e71f19dfde1a969d42e0660cc786432b3500 (diff)
downloadports-932db7c46c9a269808dfa67ea02746b350c194d8.tar.gz
ports-932db7c46c9a269808dfa67ea02746b350c194d8.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Notes
Notes: svn path=/head/; revision=321957
Diffstat (limited to 'audio/wmsmixer')
-rw-r--r--audio/wmsmixer/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/audio/wmsmixer/Makefile b/audio/wmsmixer/Makefile
index cd28c32b4f87..3325cba808fd 100644
--- a/audio/wmsmixer/Makefile
+++ b/audio/wmsmixer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmsmixer
-# Date created: 2 April 2001
-# Whom: Konstantinos Konstantinidis <kkonstan@daemon.gr>
-#
+# Created by: Konstantinos Konstantinidis <kkonstan@daemon.gr>
# $FreeBSD$
-#
PORTNAME= wmsmixer
PORTVERSION= 0.5.1
@@ -16,8 +12,9 @@ COMMENT= An audio mixer for the WindowMaker dock
PLIST_FILES= bin/wmsmixer
PORTDOCS= README
+
+USES= imake
USE_XORG= xpm
-USE_IMAKE= YES
MAKE_ARGS= CC="${CXX}" CFLAGS="${CXXFLAGS}"
do-install: