aboutsummaryrefslogtreecommitdiff
path: root/audio/x42-plugins-lv2
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2019-03-25 23:43:12 +0000
committerBrooks Davis <brooks@FreeBSD.org>2019-03-25 23:43:12 +0000
commit2d136fb16ab301b0bc87c59606734ee5d4e00abc (patch)
tree7c2024f749d9863113835ec93bef19845b04f72b /audio/x42-plugins-lv2
parent35a3fe2a430ed9dfcbfc3bed4ee751f7c094727b (diff)
downloadports-2d136fb16ab301b0bc87c59606734ee5d4e00abc.tar.gz
ports-2d136fb16ab301b0bc87c59606734ee5d4e00abc.zip
Remove dependency on llvm50
Apply upstream commit to avoid buggy code and a dependency on llvm50. https://github.com/x42/tuna.lv2/commit/8630a73317a5c44fe2ad2220eacd2b340a3e6ca6 PR: 236409 Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=496859
Diffstat (limited to 'audio/x42-plugins-lv2')
-rw-r--r--audio/x42-plugins-lv2/Makefile7
-rw-r--r--audio/x42-plugins-lv2/files/patch-meters.lv2_src_spectr.c23
-rw-r--r--audio/x42-plugins-lv2/files/patch-onsettrigger.lv2_src_spectr.c23
-rw-r--r--audio/x42-plugins-lv2/files/patch-tuna.lv2_src_spectr.c23
4 files changed, 69 insertions, 7 deletions
diff --git a/audio/x42-plugins-lv2/Makefile b/audio/x42-plugins-lv2/Makefile
index 85b171a3692e..421498dcd043 100644
--- a/audio/x42-plugins-lv2/Makefile
+++ b/audio/x42-plugins-lv2/Makefile
@@ -42,13 +42,6 @@ OPTIONS_DEFAULT_i386= SSE
SSE_MAKE_ARGS= PORT_SIMD_FLAGS="-msse -msse2 -mfpmath=sse"
-# It suffers from the regression in clang-6: https://bugs.llvm.org/show_bug.cgi?id=36915
-LLVM_VER= 50
-BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
-CPP= clang-cpp${LLVM_VER}
-CC= clang${LLVM_VER}
-CXX= clang++${LLVM_VER}
-
post-patch:
@${REINPLACE_CMD} 's| -O3||' \
${WRKSRC}/*.lv2/Makefile
diff --git a/audio/x42-plugins-lv2/files/patch-meters.lv2_src_spectr.c b/audio/x42-plugins-lv2/files/patch-meters.lv2_src_spectr.c
new file mode 100644
index 000000000000..7b3937885aa6
--- /dev/null
+++ b/audio/x42-plugins-lv2/files/patch-meters.lv2_src_spectr.c
@@ -0,0 +1,23 @@
+--- meters.lv2/src/spectr.c.orig
++++ meters.lv2/src/spectr.c
+@@ -30,10 +30,17 @@
+ # define csqrt(XX) std::sqrt(XX)
+ # define creal(XX) std::real(XX)
+ # define cimag(XX) std::imag(XX)
+-# define _I ((complex_t)(1i))
+- #ifdef __cpp_lib_complex_udls
++
++# ifdef __cpp_lib_complex_udls
+ using namespace std::literals::complex_literals;
+- #endif
++# endif
++
++# if defined __clang_major__ && __clang_major__ > 4
++# define _I (std::complex<double>(0.0,1.0))
++# else
++# define _I ((complex_t)(1i))
++# endif
++
+ typedef std::complex<double> complex_t;
+ #else
+ # include <complex.h>
diff --git a/audio/x42-plugins-lv2/files/patch-onsettrigger.lv2_src_spectr.c b/audio/x42-plugins-lv2/files/patch-onsettrigger.lv2_src_spectr.c
new file mode 100644
index 000000000000..2361aa79f797
--- /dev/null
+++ b/audio/x42-plugins-lv2/files/patch-onsettrigger.lv2_src_spectr.c
@@ -0,0 +1,23 @@
+--- onsettrigger.lv2/src/spectr.c.orig
++++ onsettrigger.lv2/src/spectr.c
+@@ -30,10 +30,17 @@
+ # define csqrt(XX) std::sqrt(XX)
+ # define creal(XX) std::real(XX)
+ # define cimag(XX) std::imag(XX)
+-# define _I ((complex_t)(1i))
+- #ifdef __cpp_lib_complex_udls
++
++# ifdef __cpp_lib_complex_udls
+ using namespace std::literals::complex_literals;
+- #endif
++# endif
++
++# if defined __clang_major__ && __clang_major__ > 4
++# define _I (std::complex<double>(0.0,1.0))
++# else
++# define _I ((complex_t)(1i))
++# endif
++
+ typedef std::complex<double> complex_t;
+ #else
+ # include <complex.h>
diff --git a/audio/x42-plugins-lv2/files/patch-tuna.lv2_src_spectr.c b/audio/x42-plugins-lv2/files/patch-tuna.lv2_src_spectr.c
new file mode 100644
index 000000000000..ea061d9a23bd
--- /dev/null
+++ b/audio/x42-plugins-lv2/files/patch-tuna.lv2_src_spectr.c
@@ -0,0 +1,23 @@
+--- tuna.lv2/src/spectr.c.orig
++++ tuna.lv2/src/spectr.c
+@@ -30,10 +30,17 @@
+ # define csqrt(XX) std::sqrt(XX)
+ # define creal(XX) std::real(XX)
+ # define cimag(XX) std::imag(XX)
+-# define _I ((complex_t)(1i))
+- #ifdef __cpp_lib_complex_udls
++
++# ifdef __cpp_lib_complex_udls
+ using namespace std::literals::complex_literals;
+- #endif
++# endif
++
++# if defined __clang_major__ && __clang_major__ > 4
++# define _I (std::complex<double>(0.0,1.0))
++# else
++# define _I ((complex_t)(1i))
++# endif
++
+ typedef std::complex<double> complex_t;
+ #else
+ # include <complex.h>