aboutsummaryrefslogtreecommitdiff
path: root/audio/yoshimi
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-05-31 14:30:49 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-05-31 14:30:49 +0000
commit2f2f7b710e0811a69eae953937b3593543e87860 (patch)
tree8d8e2294daae032e4a6a500016c5678b0f7c0aa6 /audio/yoshimi
parenta71b7eab178253f755a489b9fcddaa3aebcb970b (diff)
downloadports-2f2f7b710e0811a69eae953937b3593543e87860.tar.gz
ports-2f2f7b710e0811a69eae953937b3593543e87860.zip
audio/yoshimi: Unbreak after ports r536573
src/LV2_Plugin/YoshimiLV2Plugin.cpp:80:5: error: cannot initialize a member subobject of type 'LV2_Handle (*)(const struct LV2_Descriptor *, double, const char *, const LV2_Feature *const *)' (aka 'void *(*)(const LV2_Descriptor *, double, const char *, const LV2_Feature *const *)') with an lvalue of type 'LV2_Handle (const struct _LV2_Descriptor *, double, const char *, const LV2_Feature *const *)' (aka 'void *(const _LV2_Descriptor *, double, const char *, const LV2_Feature *const *)'): type mismatch at 1st parameter ('const struct LV2_Descriptor *' vs 'const struct _LV2_Descriptor *') YoshimiLV2Plugin::instantiate, ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/LV2_Plugin/YoshimiLV2Plugin.cpp:93:5: error: cannot initialize a member subobject of type 'LV2_Handle (*)(const struct LV2_Descriptor *, double, const char *, const LV2_Feature *const *)' (aka 'void *(*)(const LV2_Descriptor *, double, const char *, const LV2_Feature *const *)') with an lvalue of type 'LV2_Handle (const struct _LV2_Descriptor *, double, const char *, const LV2_Feature *const *)' (aka 'void *(const _LV2_Descriptor *, double, const char *, const LV2_Feature *const *)'): type mismatch at 1st parameter ('const struct LV2_Descriptor *' vs 'const struct _LV2_Descriptor *') YoshimiLV2Plugin::instantiate, ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/LV2_Plugin/YoshimiLV2Plugin.cpp:396:34: error: no matching constructor for initialization of 'YoshimiLV2Plugin' YoshimiLV2Plugin *inst = new YoshimiLV2Plugin(synth, sample_rate, bundle_path, features, desc); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/LV2_Plugin/YoshimiLV2Plugin.cpp:257:19: note: candidate constructor not viable: cannot convert argument of incomplete type 'const struct _LV2_Descriptor *' to 'const LV2_Descriptor *' for 5th argument YoshimiLV2Plugin::YoshimiLV2Plugin(SynthEngine *synth, double sampleRate, const char *bundlePath, const LV2_Feature *const *features, const LV2_Descriptor *desc): ^ src/LV2_Plugin/YoshimiLV2Plugin.h:47:7: note: candidate constructor (the implicit copy constructor) not viable: requires 1 argument, but 5 were provided class YoshimiLV2Plugin : public MusicIO ^ src/LV2_Plugin/YoshimiLV2Plugin.cpp:833:5: error: cannot initialize a member subobject of type 'LV2UI_Handle (*)(const struct LV2UI_Descriptor *, const char *, const char *, LV2UI_Write_Function, LV2UI_Controller, LV2UI_Widget *, const LV2_Feature *const *)' (aka 'void *(*)(const LV2UI_Descriptor *, const char *, const char *, void (*)(void *, unsigned int, unsigned int, unsigned int, const void *), void *, void **, const LV2_Feature *const *)') with an lvalue of type 'LV2UI_Handle (const _LV2UI_Descriptor *, const char *, const char *, LV2UI_Write_Function, LV2UI_Controller, LV2UI_Widget *, const LV2_Feature *const *)' (aka 'void *(const _LV2UI_Descriptor *, const char *, const char *, void (*)(void *, unsigned int, unsigned int, unsigned int, const void *), void *, void **, const LV2_Feature *const *)'): type mismatch at 1st parameter ('const struct LV2UI_Descriptor *' vs 'const _LV2UI_Descriptor *') YoshimiLV2PluginUI::instantiate, ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Notes
Notes: svn path=/head/; revision=537166
Diffstat (limited to 'audio/yoshimi')
-rw-r--r--audio/yoshimi/Makefile3
-rw-r--r--audio/yoshimi/distinfo4
2 files changed, 6 insertions, 1 deletions
diff --git a/audio/yoshimi/Makefile b/audio/yoshimi/Makefile
index bd986586fc32..05ddd0215f69 100644
--- a/audio/yoshimi/Makefile
+++ b/audio/yoshimi/Makefile
@@ -4,6 +4,9 @@ PORTNAME= yoshimi
DISTVERSION= 1.7.1
CATEGORIES= audio
+PATCH_SITES= https://github.com/Yoshimi/yoshimi/commit/
+PATCHFILES= 86996cbb235f0fe138ae814a6758c2c8ba1c2a38.patch:-p1
+
MAINTAINER= tobik@FreeBSD.org
COMMENT= Sophisticated software synthesizer
diff --git a/audio/yoshimi/distinfo b/audio/yoshimi/distinfo
index d397c6e18599..cd53d615c645 100644
--- a/audio/yoshimi/distinfo
+++ b/audio/yoshimi/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1587377885
+TIMESTAMP = 1590934438
SHA256 (Yoshimi-yoshimi-1.7.1_GH0.tar.gz) = b75560761d7abebf7e901bd2b0dd1f55650cab2c3ff551f7e4820425ce325c28
SIZE (Yoshimi-yoshimi-1.7.1_GH0.tar.gz) = 10067045
+SHA256 (86996cbb235f0fe138ae814a6758c2c8ba1c2a38.patch) = e5b422e9ad25bb0b1b474a904be153d5e87e977b956c6783accdf0b981718da2
+SIZE (86996cbb235f0fe138ae814a6758c2c8ba1c2a38.patch) = 3463