aboutsummaryrefslogtreecommitdiff
path: root/audio/zinf
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-10-24 14:17:53 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-10-24 14:17:53 +0000
commit60750aed3ac6018f8987db481432543174f924b5 (patch)
tree059ce4447856ad01b82610870e4be1ed6af8db66 /audio/zinf
parenta1d2d400a1d85714dd2e92336e0ee2214902968e (diff)
downloadports-60750aed3ac6018f8987db481432543174f924b5.tar.gz
ports-60750aed3ac6018f8987db481432543174f924b5.zip
Update to 2.2.1
PR: 44221 Submitted by: tkato@prontomail.com
Notes
Notes: svn path=/head/; revision=68734
Diffstat (limited to 'audio/zinf')
-rw-r--r--audio/zinf/Makefile46
-rw-r--r--audio/zinf/distinfo2
-rw-r--r--audio/zinf/files/patch-Makefile.in19
-rw-r--r--audio/zinf/files/patch-aa49
-rw-r--r--audio/zinf/files/patch-ac11
-rw-r--r--audio/zinf/files/patch-ad8
-rw-r--r--audio/zinf/pkg-plist6
7 files changed, 78 insertions, 63 deletions
diff --git a/audio/zinf/Makefile b/audio/zinf/Makefile
index c07b634fca66..089fe874592b 100644
--- a/audio/zinf/Makefile
+++ b/audio/zinf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zinf
-PORTVERSION= 2.2.0
+PORTVERSION= 2.2.1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,26 +15,29 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= musicbrainz.2:${PORTSDIR}/audio/musicbrainz \
- ttf.4:${PORTSDIR}/print/freetype \
id3:${PORTSDIR}/audio/id3lib
-USE_PERL5= yes
-USE_GNOMENG= yes
-USE_GNOME= gtk12 gdkpixbuf gnomehier
USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehier gdkpixbuf
WANT_GNOME= yes
+USE_PERL5= yes
+USE_FREETYPE= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOCONF_VER=213
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
- -I${LOCALBASE}/include/freetype1" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS= -I${LOCALBASE}/include/freetype1 -I${LOCALBASE}/include \
+ ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
-CFLAGS+= "-D_M_IX86"
+CPPFLAGS+= "-D_M_IX86"
.elif ${ARCH} == "alpha"
-CFLAGS+= "-D_M_ALPHA"
+CPPFLAGS+= "-D_M_ALPHA"
.endif
.if ${HAVE_GNOME:Mesound}!="" || defined(WITH_ALL_PLUGINS)
@@ -62,6 +65,12 @@ CONFIGURE_ARGS+= --disable-vorbis
PLIST_SUB+= VORBIS="@comment "
.endif
+# Stop a flood of complaints and PRs from people who can't be bothered
+# to keep their ports and packages up to date.
+.if exists(${LOCALBASE}/include/freetype/freetype.h)
+.error UPGRADE print/freetype TO CURRENT VERSION!
+.endif
+
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "You may use the following build options:"
@@ -73,22 +82,15 @@ pre-everything::
@${ECHO_MSG} "WITH_ALL_PLUGINS=yes build with all plugins"
@${ECHO_MSG}
-# Stop a flood of complaints and PRs from people who can't be bothered
-# to keep their ports and packages up to date.
-pre-extract:
- @test -d ${LOCALBASE}/include/freetype1/freetype && true \
- || { ${ECHO_MSG} '===> UPGRADE print/freetype TO CURRENT VERSION!';false; }
+post-patch:
+ @${REINPLACE_CMD} -e 's|\[en_US.ISO8859-1\]||g ; \
+ s|/usr/share/pixmaps|${PREFIX}/share/gnome/pixmaps|g' \
+ ${WRKSRC}/installer/unix/linux/Zinf.desktop
post-install:
@${MKDIR} ${PREFIX}/etc/sdr/plugins
${INSTALL_DATA} ${FILESDIR}/sdr2.plugin.S100.audio.rtp.mpa.zinf \
${PREFIX}/etc/sdr/plugins
- -${MKDIR} ${PREFIX}/share/gnome/apps/Audio
- ${INSTALL_DATA} ${WRKSRC}/installer/unix/linux/Zinf.desktop \
- ${PREFIX}/share/gnome/apps/Audio/
- -${MKDIR} ${PREFIX}/share/pixmaps
- ${INSTALL_DATA} ${WRKSRC}/installer/unix/linux/zinf.png \
- ${PREFIX}/share/pixmaps/zinf.png
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/zinf
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
.include <bsd.port.post.mk>
diff --git a/audio/zinf/distinfo b/audio/zinf/distinfo
index fd6b6abb3140..5c608f70cddf 100644
--- a/audio/zinf/distinfo
+++ b/audio/zinf/distinfo
@@ -1 +1 @@
-MD5 (zinf-2.2.0.tar.gz) = 0484ae0c4a462a347054892b32fdcfe9
+MD5 (zinf-2.2.1.tar.gz) = 62d603f89341a0e788451498138b962e
diff --git a/audio/zinf/files/patch-Makefile.in b/audio/zinf/files/patch-Makefile.in
index 322cd1f555b0..2904e6a6365a 100644
--- a/audio/zinf/files/patch-Makefile.in
+++ b/audio/zinf/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Mon Sep 30 01:27:04 2002
-+++ Makefile.in Mon Sep 30 01:29:57 2002
-@@ -142,13 +142,6 @@
+--- Makefile.in.orig Mon Jun 24 08:44:27 2002
++++ Makefile.in Thu Oct 17 09:19:30 2002
+@@ -142,10 +142,10 @@
install-zinf: zinf
$(mkinstalldirs) $(DESTDIR)$(bindir)
$(INSTALL_PROGRAM) zinf $(DESTDIR)$(bindir)
@@ -8,9 +8,10 @@
- $(INSTALL_DATA) installer/unix/linux/zinf.png $(GTK_PREFIX)/share/pixmaps
- $(mkinstalldirs) /usr/share/gnome/apps/Audio
- $(INSTALL_DATA) installer/unix/linux/Zinf.desktop $(GTK_PREFIX)/share/gnome/apps/Audio
-- if test -f "MakeTheme"; then \
-- $(INSTALL_PROGRAM) MakeTheme $(DESTDIR)$(bindir);\
-- fi;
-
- uninstall-zinf:
- -${RM} $(DESTDIR)$(bindir)/zinf
++ $(mkinstalldirs) $(DESTDIR)$(datadir)/gnome/pixmaps
++ $(INSTALL_DATA) installer/unix/linux/zinf.png $(DESTDIR)$(datadir)/gnome/pixmaps
++ $(mkinstalldirs) $(DESTDIR)$(datadir)/gnome/apps/Audio
++ $(INSTALL_DATA) installer/unix/linux/Zinf.desktop $(DESTDIR)$(datadir)/gnome/apps/Audio
+ if test -f "MakeTheme"; then \
+ $(INSTALL_PROGRAM) MakeTheme $(DESTDIR)$(bindir);\
+ fi;
diff --git a/audio/zinf/files/patch-aa b/audio/zinf/files/patch-aa
index e9529418ee8e..a3a07f1f1ede 100644
--- a/audio/zinf/files/patch-aa
+++ b/audio/zinf/files/patch-aa
@@ -1,6 +1,6 @@
---- configure.in.orig Mon Jun 24 01:44:27 2002
-+++ configure.in Sat Aug 3 22:49:49 2002
-@@ -172,8 +172,8 @@
+--- configure.in.orig Sat Oct 12 02:57:17 2002
++++ configure.in Thu Oct 17 09:56:22 2002
+@@ -170,8 +170,8 @@
;;
freebsd*)
host_os="freebsd"
@@ -11,7 +11,7 @@
;;
netbsd*)
host_os="freebsd"
-@@ -325,8 +325,10 @@
+@@ -323,8 +323,10 @@
esd_micro_version=`$ESD_CONFIG $esd_config_args --version | \
sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
ac_save_CFLAGS="$CFLAGS"
@@ -22,7 +22,7 @@
LIBS="$LIBS $ESD_LIBS"
rm -f conf.esdtest
AC_MSG_CHECKING(for ESD - version >= $min_esd_version)
-@@ -385,7 +387,7 @@
+@@ -383,7 +385,7 @@
}
],, have_esound=false, have_esound=false)
@@ -31,7 +31,7 @@
LIBS="$ac_save_LIBS"
AC_LANG_RESTORE
rm -f conf.esdtest
-@@ -412,7 +414,7 @@
+@@ -410,7 +412,7 @@
dnl optional freetype support..
save_CPPFLAGS="$CPPFLAGS"
@@ -40,7 +40,7 @@
AC_LANG_SAVE
AC_LANG_C
AC_CHECK_HEADERS(freetype.h, have_freetype="true", have_freetype="false")
-@@ -459,9 +461,9 @@
+@@ -460,9 +462,9 @@
gtk_config_major=`$GTK_CONFIG --version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
gtk_config_minor=`$GTK_CONFIG --version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
gtk_config_micro=`$GTK_CONFIG --version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
@@ -52,7 +52,7 @@
LIBS="$GTK_LIBS $LIBS"
AC_TRY_RUN([
-@@ -488,7 +490,7 @@
+@@ -489,7 +491,7 @@
gtk_major_version, gtk_minor_version, gtk_micro_version);
return 1;
}], , have_gtk=false, have_gtk=false])
@@ -61,7 +61,7 @@
LIBS="$ac_save_LIBS"
if test "$have_gtk" = "false"; then
AC_MSG_RESULT(no)
-@@ -509,7 +511,7 @@
+@@ -510,7 +512,7 @@
OSINC="$OSINC -I$srcdir/ui/download/unix/include"
OSINC="$OSINC -I$srcdir/ui/musicbrowser/include"
OSINC="$OSINC -I$srcdir/ftc/kjofol"
@@ -70,7 +70,7 @@
AC_DEFINE(HAVE_GTK)
else
GTK_CFLAGS=""
-@@ -530,18 +532,10 @@
+@@ -531,18 +533,10 @@
AC_SUBST(GTK_PREFIX)
AC_SUBST(EXTRALIBS)
@@ -91,7 +91,7 @@
ORBIT_LIBS=""
ORBIT_IDL=""
-@@ -651,7 +645,7 @@
+@@ -652,7 +646,7 @@
alsa_min_major_version=0
alsa_min_minor_version=5
alsa_min_micro_version=0
@@ -100,7 +100,7 @@
ac_save_LIBS="$LIBS"
LIBS="$LIBS -lasound"
-@@ -696,7 +690,7 @@
+@@ -697,7 +691,7 @@
], , have_alsa=false, have_alsa=false
)
AC_LANG_RESTORE
@@ -109,7 +109,7 @@
LIBS="$ac_save_LIBS"
if test "$have_alsa" = "false"; then
AC_MSG_RESULT(no)
-@@ -716,6 +710,9 @@
+@@ -717,6 +711,9 @@
AC_MSG_RESULT([compiling alsa pmo plugin])
fi
@@ -119,7 +119,7 @@
AC_CHECK_LIB(ogg, ogg_sync_init, have_ogg="yes",)
AC_CHECK_LIB(vorbisfile, ov_info, have_vorbis="yes",, -lvorbis -logg)
-@@ -726,6 +723,7 @@
+@@ -727,6 +724,7 @@
OSDEPPLUGINS="$OSDEPPLUGINS plugins/vorbis.mdf";
AC_MSG_RESULT([compiling vorbis codec plugin])
fi
@@ -127,7 +127,16 @@
fi
ID3_LIBS=""
-@@ -813,9 +811,9 @@
+@@ -747,7 +745,7 @@
+ if test x$ARTSCCONFIG = x -o x$ARTSCCONFIG = x'"$ARTSCCONFIG"'; then
+ : # arts isn't installed
+ else
+- CFLAGS="$CFLAGS `$ARTSCCONFIG --cflags`"
++ CPPFLAGS="$CPPFLAGS `$ARTSCCONFIG --cflags`"
+ AC_TRY_COMPILE([
+ #include <artsc.h>
+ ],[
+@@ -814,9 +812,9 @@
gdk_pixbuf_micro_version=`$GDK_PIXBUF_CONFIG $gdk_pixbuf_config_args --version | \
sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
if test "x$enable_gdk_pixbuftest" = "xyes" ; then
@@ -139,7 +148,7 @@
LIBS="$LIBS $GDK_PIXBUF_LIBS"
dnl
dnl Now check if the installed GDK_PIXBUF is sufficiently new. (Also sanity
-@@ -877,7 +875,7 @@
+@@ -878,7 +876,7 @@
}
],, no_gdk_pixbuf=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
@@ -148,7 +157,7 @@
LIBS="$ac_save_LIBS"
fi
fi
-@@ -896,7 +894,7 @@
+@@ -897,7 +895,7 @@
:
else
echo "*** Could not run GDK_PIXBUF test program, checking why..."
@@ -157,7 +166,7 @@
LIBS="$LIBS $GDK_PIXBUF_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-@@ -915,7 +913,7 @@
+@@ -916,7 +914,7 @@
echo "*** exact error that occured. This usually means GDK_PIXBUF was incorrectly installed"
echo "*** or that you have moved GDK_PIXBUF since it was installed. In the latter case, you"
echo "*** may want to edit the gdk-pixbuf-config script: $GDK_PIXBUF_CONFIG" ])
@@ -166,7 +175,7 @@
LIBS="$ac_save_LIBS"
fi
fi
-@@ -927,8 +925,8 @@
+@@ -928,8 +926,8 @@
AC_SUBST(GDK_PIXBUF_LIBS)
rm -f conf.gdk_pixbuftest
@@ -177,7 +186,7 @@
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
-@@ -938,7 +936,7 @@
+@@ -939,7 +937,7 @@
echo "*** Download the library from "
echo "*** http://www.musicbrainz.org/download.html"
echo "***"
diff --git a/audio/zinf/files/patch-ac b/audio/zinf/files/patch-ac
index 3ccdbc6010ff..99d352c4a6db 100644
--- a/audio/zinf/files/patch-ac
+++ b/audio/zinf/files/patch-ac
@@ -1,8 +1,11 @@
---- Makefile.header.in.orig Sat Aug 3 22:50:21 2002
-+++ Makefile.header.in Sat Aug 3 22:51:50 2002
-@@ -72,7 +72,7 @@
+--- Makefile.header.in.orig Mon Jun 24 08:44:27 2002
++++ Makefile.header.in Fri Oct 18 06:28:36 2002
+@@ -70,9 +70,9 @@
- INCLUDES = -I. -I$(srcdir)/lib/gdbm -I$(srcdir)/base/include -I$(srcdir)/config -I$(srcdir)/io/include -I$(srcdir)/ui/include -I$(srcdir)/lmc/include -I$(srcdir)/io/soundcard/unix/$(UNIX_AUDIO_API)/include -I$(srcdir)/lmc/xingmp3/include -I$(srcdir)/lmc/cd/include -I$(srcdir)/plm/portable/pmp300/sba -I$(srcdir)/lib/xml/include -I$(srcdir)/lib/zlib/include -I$(srcdir)/lib/unzip/include -I$(srcdir)/io/cd/unix/include -I$(srcdir)/base/aps -I$(srcdir)/io/wavout/include -I$(srcdir)/ui/lcd/include -I$(srcdir)/ui/irman/include -I$(srcdir)/lib/http/include -I$(srcdir)/io/signature/include -I$(srcdir)/plm/metadata/id3v2 -I$(srcdir)/lmc/wav/include $(OSINC)
+ OSDEPOBJ = @OSDEPOBJ@
+
+-INCLUDES = -I. -I$(srcdir)/lib/gdbm -I$(srcdir)/base/include -I$(srcdir)/config -I$(srcdir)/io/include -I$(srcdir)/ui/include -I$(srcdir)/lmc/include -I$(srcdir)/io/soundcard/unix/$(UNIX_AUDIO_API)/include -I$(srcdir)/lmc/xingmp3/include -I$(srcdir)/lmc/cd/include -I$(srcdir)/plm/portable/pmp300/sba -I$(srcdir)/lib/xml/include -I$(srcdir)/lib/zlib/include -I$(srcdir)/lib/unzip/include -I$(srcdir)/io/cd/unix/include -I$(srcdir)/base/aps -I$(srcdir)/io/wavout/include -I$(srcdir)/ui/lcd/include -I$(srcdir)/ui/irman/include -I$(srcdir)/lib/http/include -I$(srcdir)/io/signature/include -I$(srcdir)/plm/metadata/id3v2 -I$(srcdir)/lmc/wav/include $(OSINC)
++INCLUDES = -I. -I$(srcdir)/lib/gdbm -I$(srcdir)/base/include -I$(srcdir)/config -I$(srcdir)/io/include -I$(srcdir)/ui/include -I$(srcdir)/lmc/include -I$(srcdir)/io/soundcard/unix/$(UNIX_AUDIO_API)/include -I$(srcdir)/lmc/xingmp3/include -I$(srcdir)/lmc/cd/include -I$(srcdir)/plm/portable/pmp300/sba -I$(srcdir)/lib/xml/include -I$(srcdir)/lib/zlib/include -I$(srcdir)/lib/unzip/include -I$(srcdir)/io/cd/unix/include -I$(srcdir)/base/aps -I$(srcdir)/io/wavout/include -I$(srcdir)/ui/lcd/include -I$(srcdir)/ui/irman/include -I$(srcdir)/lib/http/include -I$(srcdir)/io/signature/include -I$(srcdir)/lmc/wav/include $(OSINC)
-CXXFLAGS = $(EXTRA_CXXFLAGS)
+CXXFLAGS = @CXXFLAGS@ -D_REENTRANT
diff --git a/audio/zinf/files/patch-ad b/audio/zinf/files/patch-ad
index 6657f35b715e..d3e953c4ba52 100644
--- a/audio/zinf/files/patch-ad
+++ b/audio/zinf/files/patch-ad
@@ -1,11 +1,11 @@
---- Makefile-plugins.in.orig Sat Aug 3 22:53:07 2002
-+++ Makefile-plugins.in Sat Aug 3 22:54:02 2002
+--- Makefile-plugins.in.orig Mon Jun 24 19:03:03 2002
++++ Makefile-plugins.in Thu Oct 17 10:02:34 2002
@@ -200,7 +200,7 @@
UNIXZINFUIOBJ += ui/zinf/unix/src/GTKPreferenceWindow.o
UNIXZINFUIOBJ += ui/zinf/unix/src/GTKFileSelector.o
UNIXZINFUIOBJ += ui/musicbrowser/unix/src/gtkmessagedialog.o
--UNIXZINFUILIBS = $(TTF_LIBS) $(GDK_PIXBUF_LIBS)
-+UNIXZINFUILIBS = $(TTF_LIBS) $(GDK_PIXBUF_LIBS) $(GTK_LIBS)
+-UNIXZINFUILIBS = $(GDK_PIXBUF_LIBS) -static $(TTF_LIBS)
++UNIXZINFUILIBS = $(GDK_PIXBUF_LIBS) $(TTF_LIBS)
plugins/zinf.ui: $(ZINFUIOBJ)
$(LINKMOD) -o $@ $(ZINFUIOBJ) $(ZINFUILIBS)
diff --git a/audio/zinf/pkg-plist b/audio/zinf/pkg-plist
index 9f9b6c84591f..b898abc7af02 100644
--- a/audio/zinf/pkg-plist
+++ b/audio/zinf/pkg-plist
@@ -5,8 +5,6 @@ lib/zinf/plugins/cd.lmc
lib/zinf/plugins/cd.pmo
lib/zinf/plugins/download.ui
%%ESOUND%%lib/zinf/plugins/esound.pmo
-lib/zinf/plugins/zinf.ui
-lib/zinf/plugins/zinfcmd.ui
lib/zinf/plugins/httpinput.pmi
lib/zinf/plugins/id3v1.mdf
lib/zinf/plugins/id3v2.mdf
@@ -31,8 +29,10 @@ lib/zinf/plugins/wavout.pmo
lib/zinf/plugins/winamp.ftf
lib/zinf/plugins/winamp_theme.xml
lib/zinf/plugins/xingmp3.lmc
+lib/zinf/plugins/zinf.ui
+lib/zinf/plugins/zinfcmd.ui
share/gnome/apps/Audio/Zinf.desktop
-share/pixmaps/zinf.png
+share/gnome/pixmaps/zinf.png
share/zinf/themes/Aquatica.fat
share/zinf/themes/Zinf.fat
share/zinf/themes/ZinfClassic.fat